I cant install NC :( Internal Server Error


I installed many instances of NC for a long time, never had any issues with it generally it is very straight forward except this one. I cant even get to the install screen.

I am using Debian Stretch, Apache/2.4.25 (Debian), PHP 7.3.6-1, mysql Ver 15.1 Distrib 10.1.38-MariaDB

I downloaded https://download.nextcloud.com/server/releases/nextcloud-16.0.1.zip

I then unzipped it, gave proper www-data permissions etc. The I tried opened the NC page, nomatter what I do I keep getting the erros below

There are no errors in Apache’s error.log

Internal Server Error
The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.
{"reqId":"gvZGNLuzaEOAAnP7m6iC","level":3,"time":"July 01, 2019 02:11:40","remoteAddr":"-IP-","user":"--","app":"base","method":"GET","url":"\/NEXT\/index.php","message":{"Exception":"ErrorException","Message":"session_name(): session.name cannot be a numeric or empty ''","Code":0,"Trace":[{"function":"trapError","class":"OC\\Session\\Internal","type":"->","args":[2,"session_name(): session.name cannot be a numeric or empty ''","\/var\/www\/html\/NEXT\/lib\/private\/Session\/Internal.php",207,{"functionName":"session_name","parameters":[""],"silence":false}]},{"function":"session_name","args":[""]},{"file":"\/var\/www\/html\/NEXT\/lib\/private\/Session\/Internal.php","line":207,"function":"call_user_func_array","args":["session_name",[""]]},{"file":"\/var\/www\/html\/NEXT\/lib\/private\/Session\/Internal.php","line":53,"function":"invoke","class":"OC\\Session\\Internal","type":"->","args":["session_name",[""]]},{"file":"\/var\/www\/html\/NEXT\/lib\/base.php","line":424,"function":"__construct","class":"OC\\Session\\Internal","type":"->","args":[""]},{"file":"\/var\/www\/html\/NEXT\/lib\/base.php","line":642,"function":"initSession","class":"OC","type":"::","args":[]},{"file":"\/var\/www\/html\/NEXT\/lib\/base.php","line":1056,"function":"init","class":"OC","type":"::","args":[]},{"file":"\/var\/www\/html\/NEXT\/index.php","line":40,"args":["\/var\/www\/html\/NEXT\/lib\/base.php"],"function":"require_once"}],"File":"\/var\/www\/html\/NEXT\/lib\/private\/Session\/Internal.php","Line":183,"CustomMessage":"--"},"userAgent":"Mozilla\/5.0 (X11; Linux x86_64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/73.0.3683.75 Safari\/537.36","version":""}

Hello man, just i 've this problem some days ago. Sadly, i didn’t take note about the solution and i don’t remember it very well. Furthermore, i’ve some other problems. In fact, i began to install Nextcloud 2 weeks ago, so i found a lot of issues. At least i tried 4 installations until to get it work fine.

Said this, are you maybe trying to install NC on a VPS with less than 1Gb of RAM? I remember that it was one of my problems, and it returned to me errors without explanation. I think that this error you share here was one of them.

In my case i began the installation again over an VPS of 1Gb RAM, and it was all fine from there :wink:

By the way (for other readers) i successfully install NC on the cloud hosting named DreamObjects of Dreamhost, what i can only recommend. Now i have installed Nextcloud on a 1Gb RAM + “1 core” VPS and another instance of same size with OnlyOffice. Each one usually use only less than 500Mb, but sometimes (you know: opening files, blah bla blah…) can up until 900Mb.

It’s true, i’m only “playing” (testing) NC+OnlyOffice for my own use (trying to go get Google independence, hehehe). But it runs. Even i discovered fascinated the ability to stream video if you put a movie in Files app !! :-o

I’m really in love again. Thanks NC team!

1 Like

Rememeber too that you can check these log files:

	sudo tail -n 100 /var/log/syslog
	sudo tail -n 100 /var/log/apache2/error.log
	sudo tail -n 100 /var/www/html/data/nextcloud.log

Depending on your type of error :wink:

Thanks for the reply. The VPS memory could be the issue, good catch with that one. I am going to take a look at to see if I can increase it.

Unfortunately increasing the VPS ram to 1GB did not help. I do not know what else to try here :frowning:

Check your webserver log for internal server errors, there are many causes that create this error and the webserver logs should be a bit more specific. 1 GB RAM is not very much, so it is possible that you must adjust the settings of your services (webserver, database, php) properly.

The thing is, this does not create any line sin the apache log. I already pasted the error log from nextcloud.log in my initial post.

It’s very unusual that you have nothing in the apache error logs. Check your configuration, you perhaps have to increase the log level of apache to get this logged. One reason it can’t be logged could be if the drive is broken or full.