I cant get my password

i just bought a storage with cloudamo.
i already have a account with nextcloud but forgot the password,
ive tried the trick with the occ but it cant find the nextcloud folder to work?
is there someone that could help me reset the password once and for all please?

What operating system is running on the server? Do you have CLI access, or at least via FTP to the file system?

Without that, not much can be done without the help of the support team. I would never try to run NC on a machine where I have no root access.

kubuntu 20.04, i have root access

sorry yes i have client access

So the nextcloud folder should be in /var/www or /var/www/html. There you should find the config/config.php file. The occ command must be executed there with the privileges of the web server. That is www-data, if you did not change the defaults.

so could you possible give me the commands to type in i might take a while trying to figure it out


i dont think i have a www folder in var

On a Ubuntu server, it should be there. Is apache2 or nginx installed?

about to install apache2 right now

/var/www/html$ sudo -u www-data php /var/www/nextcloud/occ user:resetpassword admin

Still, you need to know where your nextcloud folder is. You said it is already installed. Nextcloud without a web server makes no sense.

im sorry i didnt need to do this before so im clueless im sorry

What about

sudo find / -name occ


sudo find /nextcloud occ
[sudo] password for chewyf:
find: ‘/nextcloud’: No such file or directory
find: ‘occ’: No such file or directory

You didn’t put the command in correctly. Please try again and don’t make typing mistakes.

The command will try to find a file on your whole disk that is named occ which you need in order to run commands

sudo find / -occ
find: unknown predicate `-occ’
chewyf@chewyf-ideacentre-700-25ISH:~$ sudo find occ
find: ‘occ’: No such file or directory

Still not the exact command. Please try again and compare it with the one that I recommended

sudo find / -name occ
find: ‘/run/user/1000/doc’: Permission denied
find: ‘/proc/7770/task/7770/net’: Invalid argument
find: ‘/proc/7770/net’: Invalid argument
find: ‘/tmp/.mount_Nextcl6WNWpE’: Permission denied