I cannot use own server collabora online

Dear All,

I follow setup own server from this link https://www.allerstorfer.at/nextcloud-install-collabora-online/ everthing is working except last step “Change config nextcloue to use own server collabora online”
2021-09-27-01
I testing with this url is working
https://collabora.mydomin.com/loleaflet/dist/admin/admin.html
2021-09-23-02
https://collabora.mydomin.com/hosting/discovery
2021-09-23-03
https://collabora.mydomin.com/apps/richdocumentscode/proxy.php?status
2021-09-23-05

This is my server status
2021-09-23-06

My configure a subdomain to proxy
2021-09-23-08

This is docker status

How I can fix this problem?

Bese regards,
Spymemo

HI @spymemo

Please try the Apache configuration from here:

https://nextcloud.com/collaboraonline/

As far as I can see, the tutorial you’ve been using is missing the following lines…

# Endpoint with information about availability of various features
ProxyPass           /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0
ProxyPassReverse    /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities

1 Like

Thank you bb77 I follow your suggest already, But I have a new problem now, when I use own server


2021-09-23-11

1 Like

Are there any error messages in the Nextcloud log?

Could you please post your full configs of the Apache VirtualHosts for Nextcloud and collabora?

Also, as far as I know, Collabora is not compatible with the Nextcloud encryption, if you should use it… But i’m not a 100% sure about that.

I monitor nextcloud log when I change to own server is not have a new log, but have a log error on mysql
2021-09-23-15
And This is last nextcloud log


This is full configs of the Apache VirtualHosts for Nextcloud
2021-09-23-17
And full configs of the Apache VirtualHosts for collabora

About collabora is not compatible with the Nextcloud encryption, I don’t know before
It mean if we use Nextcloud encryption, we don’t use collabora, So what is app for edit document online for nextcloud?

Your Apache configs look OK as far as I can tell. Also the error message in the Nextcloud log unfortunatly supports my assumption, that the problem occurs because of the encryption.

Maybe it works with OnlyOffice or there is some workaround… But I have never dealt with this topic in detail and therefore cannot tell you whether there is an online office that works with Nextcloud encryption. Maybe you can search the forums or open a new thread specifically on this topic.

1 Like

Thank you bb77 for your response, Although I can’t solve this problem. But I’m more understanding of this problem.

I wasn’t planning on encryption the first time during installation. Solving problems later is difficult, I know

Thanks again for your help.

1 Like

I need to update my problem, I solved the problem now with https://forum.collaboraonline.com/t/i-cannot-use-own-server-collabora-online/616
However, I thank bb77 again for helping me.

Hmm. The reverse proxy configuration for " SSL on both ends" they linked to in the Collabora forums is identical to the one I linked to, except for the order of the entries and the one line at the very beginning with the “Options -indexes” directive…

Anyways… Glad that it worked out for you. :slight_smile: