I can’t excape from carddav/caldav warning after installation

I Install nextcloud 24 and check configuration, settings etc.
But even I change .htaccess and apache.conf file, I cant escape from warning about carddav, caldav.

My nextcloud is located at /var/www/nextcloud

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted

and .htaccess is like

<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteCond %{HTTP_USER_AGENT} DavClnt
  RewriteRule ^$ /remote.php/webdav/ [L,R=302]
  RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
  RewriteRule ^\.well-known/carddav /remote.php/dav/ [R=301,L]
  RewriteRule ^\.well-known/caldav /remote.php/dav/ [R=301,L]
  RewriteRule ^remote/(.*) remote.php [QSA,L]
  RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.* - [R=404,L]
  RewriteRule ^\.well-known/(?!acme-challenge|pki-validation) /index.php [QSA,L]
  RewriteRule ^(?:\.(?!well-known)|autotest|occ|issue|indie|db_|console).* - [R=404,L]

I checked that Document Root is /var/www/html/. THen I create another .htaccess in /var/www/html/ that described in Admin manual-Service Discovery

<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteRule ^/\.well-known/carddav /var/www/nextcloud/remote.php/dav [R=301,L]
  RewriteRule ^/\.well-known/caldav /var/www/nextcloud/remote.php/dav [R=301,L]
  RewriteRule ^/\.well-known/webfinger /var/www/nextcloud/index.php/.well-known/webfinger [R=301,L]
  RewriteRule ^/\.well-known/nodeinfo /var/www/nextcloud/index.php/.well-known/nodeinfo [R=301,L]

But again, nothing changed. Then I put same .htaccess file in /var/ww. But same warnings still goes on.
What should I do to remove those warning. And How can ne sure that I use correct .htaccess file?

Nextcloud version (eg, 20.0.5):
Operating system and version (eg, Ubuntu 20.04): Linux 5.15.0-39-generic #42-Ubuntu SMP Thu Jun 9 23:42:32 UTC 2022 x86_64
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.52 (Ubuntu) (apache2handler)
PHP version (eg, 7.4): `8.1.2

Modules loaded: Core, date, libxml, openssl, pcre, zlib, filter, hash, json, Reflection, SPL, session, standard, sodium, apache2handler, mysqlnd, PDO, xml, apcu, bcmath, bz2, calendar, ctype, curl, dom, mbstring, FFI, fileinfo, ftp, gd, gettext, gmp, iconv, igbinary, imagick, imap, intl, ldap, exif, msgpack, mysqli, pdo_mysql, Phar, posix, readline, redis, shmop, SimpleXML, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, xmlreader, xmlwriter, xsl, zip, memcached, Zend OPcache`

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Install Nextcloud
  2. Open Settings Page
  3. According to Link and web server config add given .htaccess file in /var/www/htmland restart apache. Nothing change. Then move this file into /var/www. Nothing change.

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ocqx9xhaytnp',
  'passwordsalt' => 'pLq0X3nOER4FUiyXl/zXseafetCfcO',
  'secret' => 'UkaWioceW5qLN1hHmZ+yrRvpR+mjgvKfqGPRgtVO/S1o6Rh2',
  'trusted_domains' => 
  array (
    0 => 'bulut.yasar.com.tr',
  'datadirectory' => '/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'http://bulut.yasar.com.tr/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:5432',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'B0lvad!n',
  'proxy' => 'proxy.yasar.net:8080',
  'installed' => true,

  'default_phone_region' => 'TR',

  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'redis' => 
  array (
//  'host' => '/var/run/redis/redis.sock',
  'host' => 'localhost',
  'port' => 6379,
  'timeout' => 0.0,

  'htaccess.RewriteBase' => '/nextcloud',


The output of your Apache/nginx/system log in /var/log/____:



Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.