I can not log in using Redis


#1

I updated PHP from 7.3.1 to 7.3.2 and from 7.2.14 to 7.2.15. And I have specified Redis for PHP Session. session.save_path = “tcp://127.0.0.1:6379”. I could not log in to Nextcloud immediately after that. *It is an error which does not remain in every log.
If I set session.save_path to “/var/lib/php/session”, I can log in to NC. I have set it for this now.

Redis itself seems to function normally. Specify memcache.local to Redis in config.php of NC. This seems to be functioning normally. I do not seem to be able to login when trying to use Redis for PHP session.

This happens with PHP 7.3.2 and 7.2.15, so the new version of PHP will have a big impact. This is caused by Nextcloud side, Redis, or PHP itself. Which one is it? Or was it necessary to change the setting?

I tried restarting Nginx, MariaDB, PHP-FPM, Redis, the server. And PHP session specification changed to socket(/var/run/redis/redis.sock).


Nextcloud 15.0.4, CentOS 7.6, PHP 7.3.2, 7.2.15, Nginx 1.14.1, MariaDB 10.2.21, Redis 5.0.3


#2

As far as I understood Redis cannot be used to handle PHP sessions. Check out the following discussion: https://github.com/nextcloud/server/issues/13148