Https/SSL-cert not working

So, i just installed nextcloud 21.0.1snap2 via snap package on my ubuntu20.04 server, set up my account vie web interface, added port-forwarding rules to my router, set up my cloudflare dns to point my Domain to my current ip and added my domain as trusted in config.php . Everything was working fine until here, i could access my nextcloud over the domain as well as over the local ip.
Then i ran $sudo snap run nextcloud.enable-https lets-encrypt.(same error accurs with self-signed)

Now the local IP as well as the domain get automatically redirected to https. Accessing it via local IP works fine. When I try to access it over the Domain however, firefox instantly shows “The page isn’t redirecting properly”. I dont what to do, i checked my dns and port-forwarding setting a million times and reenabled https for nextcloud to make sure i used the right domain, but still nothing.

I am happy to provide more Information right now, i dont know what configs to post tho.
My Doman is: