HTTP Error 500 while accessing "Apps"

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 28.0.1
Operating system and version (eg, Ubuntu 20.04): Linux 5.15.0-89-generic x86_64
Apache or nginx version (eg, Apache 2.4.25): currently unknown
PHP version (eg, 7.4): 8.2

The issue you are facing:

Hello all!
I’m currently struggling with a new Nextcloud installation for a few days.
I’m using a all-inkl.com webspace (shared host) if thats relevant.

First i tried the installer that is provided by all-inkl itself which i used before the install another instance of nextcloud without issues, this installer sets up the NextCloud Hub 6, after the installation everything works fine, except i can’t access the Appstore and the “System” subpage which results in the mentioned HTTP Error 500 and i can’t enable the server-side encryption
Everything else is working fine, i can connect via the desktop as well as the Android app, upload files, use CalDAV / CardDAV and so on, i need the encryption though.

Afterwards i tried the webinstaller (setup-nextcloud.php with Nextcloud Hub 7) which resulted in a smiliar error:
At the end of the installation, the installer states that he is unable to access the webstore. I can use Nextcloud and log into it, although the HTTP Error 500 still appears when trying to open the Apps.
Encryption is still not working, funny enough the “System” menu tab is working on this version.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. after every reinstallation, no difference regarding the source by clicking on “Apps”

The output of your Nextcloud log in Admin > Logging:

empty

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'xxxxxx',
  'passwordsalt' => 'xxxxxx',
  'secret' => 'xxxxxx',
  'trusted_domains' => 
  array (
    0 => 'xxxxxx',
  ),
  'datadirectory' => '/www/htdocs/xxxxxx/xxxxx/data',
  'dbtype' => 'mysql',
  'version' => '28.0.1.1',
  'overwrite.cli.url' => 'https://xxxxxx',
  'dbname' => 'xxxxxxx',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxxxxxx',
  'dbpassword' => 'xxxxxxxxxx',
  'installed' => true,
  'tempdirectory' => '/www/htdocs/xxxxx/xxxxxx/tmp',
);

The output of your Apache/nginx/system log in /var/log/____:

not accessible atm

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

empty

Additionally the Security & setup warnings:

The PHP memory limit is below the recommended value of 512 MB. 
(!!!! this can't be changed by me due to shared hosting)

The PHP OPcache module is not properly configured. See the documentation ↗ for more information.
The PHP OPcache module is not loaded. For better performance it is recommended to load it into your PHP installation.
(!!! this was configured in a prior instance, did not fix the error though)

The database is used for transactional file locking. To enhance performance, please configure memcache, if available. For more details see the documentation ↗.
No memory cache has been configured. To enhance performance, please configure a memcache, if available. For more details see the documentation ↗

500 internal server errors are logged to the nextcloud.log. Please check it. That’s where the clues will be.

The PHP OPcache module is not loaded. For better performance it is recommended to load it into your PHP installation.

These errors suggest something very wrong with your PHP installation/environment. Having OPcache disabled is highly unusual. I suggest contacting your web host. From the looks of their FAQ[1] they may give you some flexibility in configuration aspects of PHP.

[1] FAQ - Häufig gestellte Fragen & Antworten zum Webhoster ALL-INKL.COM