HTTP ERROR 500 - After installing App

Unraid ver: 6.10.3
Unraid dockers: nextcloud, mariadb
Unraid VM’s: none
Array: 12TB (106GB used)

HTTP ERROR 500 - After installing App

After installing a search app via the plugin within nextcloud, I received an error message in nextcloud that the server was unstable. I power-cycled the nextcloud docker (in unraid), and now I see this error message.

I believe that I need to use the terminal in the Nextcloud Docker in UnRaid to uninstall the app? Problem is, I don’t know how. I am struggling just to find the directory of nextcloud. Well after a few hours of cramming , i finally I believe found the nextcloud directory in the Docker terminal. I am confused what this means: root@a168f31971fd: and a168f31971fd The directory is: a168f31971fd:/config/www/nextcloud#

I tried to run the following command:

a168f31971fd:/config/www/nextcloud# sudo -u www-data php occ app:disable fulltextsearch
sudo: unknown user: www-data
sudo: error initializing audit plugin sudoers_audit

How do I run the app commands?

I installed Unraid and then nextCloud last week. It’s been a fast pace learning curve. Not knowing commands or even how to navigate the file system really suxs.

Being that I am such a newbie, I want to learn. I am soaking up all the information on this forum and the web. Please forgive my ignorance. I am in the process of learning about nextcloud file structure and Linux in general. Do you have recommendations on a tutorial, video, or the like that would guide a person with little to no knowledge?

I found this here on a post from 2019.

The occ console is located in the Nextcloud directory, so you need to change to that directory first before issuing the command to disable the app (change capital letters to fit your needs):

sudo -u www-data php occ app:disable NAME_OF_APP

If you don‘t know the name of the app, you can list all apps with:

sudo -u www-data php occ app:list

My current problem, I don’t know the command to get me to /PATH/TO/NEXTCLOUD directory in the terminal. Using Krusader in Unraid, This is the path that it shows: /1_Unraid_Shares/appdata/nextcloud/www/nextcloud/

In the terminal, I am in the root account (root@servername:`# )

I’ve been searching and testing various commands. Even as frustrating as this has been, it’s the best way for me to learn. I just found this command, and it worked for me:

root@a168f31971fd:/config/www/nextcloud# occ app:list

root@a168f31971fd:/config/www/nextcloud# occ app:disable fulltextsearch
fulltextsearch 24.0.0 disabled

So so simple, yet I made it difficult! :slight_smile: