Http connection with https

This site is accessed via an insecure HTTP protocol. Instead, we strongly recommend that you configure the server to require HTTPS, as described in our security tips.

Yes, that is a good advice. To enable https, configure your web server.

I set everything according to the instructions and still can not and I do not know where to set it

Which instructions did you follow? What is the content of your apache virtual host file?