How to stop desktop notifications for recommended apps

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 18.0.2): 18.0.4
Operating system and version (eg, Ubuntu 20.04): ?
Apache or nginx version (eg, Apache 2.4.25): ?
PHP version (eg, 7.1): 7.3

The issue you are facing:
I am getting a lot of desktop notifications regarding recommended Apps.
This is on macOS 10.14

Is this the first time you’ve seen this error? (Y/N):
No, I had this issue before where I sometimes over night got several dozen notifications.

I disabled an installed app called " Recommendations" in the hopes that would stop desktop notifications, but reenabled again when I saw this was for file recommendations.

Can I actually disabled “app recommendatins” without disabling desktop notifications all together?

Steps to replicate it:

  1. Have the desktop app running
  2. Wait for desktop notifications to flock in

The output of your Nextcloud log in Admin > Logging:

// Doesn't seem to be relevant. Can provide if I a wrong.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

// see above

The output of your Apache/nginx/system log in /var/log/____:

// see above

Just to note for others on macOS:

  1. I had to open the desktop app (top bar icon > Settings …)
  2. open the “Activity” tab
  3. find the entry with the same info as the OS notification
  4. dismiss it by clicking on the “x”

I will mark this as the solution, but the thanks goes to kesselb.

1 Like