How to start master container?

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): Nextcloud All-In-One (AIO)
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): Using Nextcloud AIO (Apache)
PHP version (eg, 7.4): Using Nextcloud AIO

The issue you are facing:
I have been running Nextcloud AIO without any issues for many months. Today, I went to update the master container but the backup can’t complete because storage is full. I am going to use another backup solution so I want to disable the built-in backup with borg.

I stopped the master container with the command:

sudo docker stop [container-id]

Now I want to start the master container again with backup disabled. The docs say you can do so by adding -e DISABLE_BACKUP_SECTION=true to the initial startup of the mastercontainer.

I tried running the following command to start the container with backup disabled:

sudo docker start [container-id] -e DISABLE_BACKUP_SECTION=true

However it shows the message unknown shorthand flag: 'e' in -e.

What is the command to restart the master container with backup disabled?

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Stop master container with sudo docker stop [container-id].
  2. Try to start master container with sudo docker start [container-id] -e DISABLE_BACKUP_SECTION=true.

There is no -e argument for docker start. This is a limitation in Docker which doesn’t support changing runtime options of existing containers.

So what are the steps for restarting Nextcloud with backup disabled?

1 Like

Basically you need to stop the mastercontainer, remove it and recreate it with changed settings.

1 Like