How to set up first day of week?

I’m trying to set up 1st day of week in Calendar as Monday, but I’m having troubles with it. I went to “Personal Info” and changed “Locale” to “English (Europe)”. It says “Week starts on Monday”. But when I go to Calendar and change view to month or week, I see week still starts on sunday! The same happen if I change locale to “English (Germany)”. Ain’t this broken?

When I change locale to “German” and keep language “English (US)”, Calendar shows properly first day of week as Monday, but days are labeled as “Mo, Di, Mi, Do, Fr, Sa, So”. So the whole interface is still in English, but days-labels are in german!

What I want is to have Monday as start of week in Calendar, and days labeled “Mon, Tue, Wed, Thu, Fri, Sat, Sun”. How can I do it?

BTW, I think there could be some “general” option for setting up locale, with individual definition for date, time, week. Independent from system locales installed…

Same problem here; also if you select ‘Spanish’ locale. In previous versions I used to be able to fix this by selecting “Ireland” as the local, but that defaults to Sunday week start now. :frowning:

Probably related to https://github.com/nextcloud/calendar/issues/2174, fixed in master, not yet released.