How to run index


#1

I am running nextcloud using the linuxserver.io docker. I have installed the nextant app from within the docker, and have installed solr on my machine manually. All is working.

I have a very naive question, however. In the wiki it talks about a bunch of commands that start with ./occ … In an installation like mine, where nextcloud is in a docker container, and solr is natively on the machine, where would occ be? How would I run these commands?


#2

This is more a question for @Ark74

Remember that Nextant is not maintained anymore and will be replaced by FullNextSearch (which is currently in ALPHA and will use ElasticSearch).


#3

occ is the main tool for administration on Nextcloud on the server side, you can manage almost anything from it included nextant.

It’s placed on your nextcloud installation directory and is used along with php, so you should run it like

sudo -u www-data php occ your_commands,arguments and paths here
(if you run debian based system)

I’m not familiar with linuxserver docker image, but you might wanna enter that image and run the occ commands within the docker image (it doesn’t matter that Solr is running on your machine).

Finally you might wanna follow/support the FullNextSearch development since that will be the next step on this matter.


#4

Just want to leave a comment here with the answer in case anyone comes by in the future.

For the LSIO docker, you map the config folder to a local storage location on your system. It goes something like /var/opt/nextcloud:/config where the left side is your actual storage and the right side in the mapping in the docker.

So, within the docker mapped config folder, the occ file is under the www directory, so just run all those commands from within there, or pointing to that. In my case I mapped the directory like above, so the occ file is in my /var/opt/nextcloud/www folder.

Thanks for the help!


#5

@antsh solutions didn’t work for me as I don’t have php installed on my server. My first attempt was to run:
docker exec -it nextcloud-container-name bash
but I could not run the occ commands as root and sudo is not available in the container so I had to add the -u www-data when connecting to the container. The two lines below worked for me.
docker exec -u www-data -it nextcloud-container-name bash
Inside the container shell run i.e:
./occ db:add-missing-indices