How to remove the registration button that is public and change the registration URL


#1

I want to remove the registration button in the homepage, and also change the default /index.php/apps/registration URL, since anyone that knows Nextcloud can easily access this URL.

I don’t want to hide the button via css, because it is useless. I want to make it stop rendering in the homepage. Any ideas? Thanks!


#2

You can edit the config.conf file, usually located in your Nextcloud directory at …/_data/config/config.php

Look for this line below, and change it to false:
simpleSignUpLink.shown' => false,


#3

Thank you very much! Just a last help, do you know how do I change the default url for registration?

I think /apps/registration/ is so easy to access, specially because I’m running a paid service.


#4

Actually it didn’t work. I empty all caches, waited 5 minutes and tried several times.

I used 'simpleSignUpLink.shown' => false,

Are you sure we are talking about the same “Register” button that has the alternative-logins"class, that is part of the registration app?


#5

Oh sorry. I thought you were referring to the footer at the standard login screen. It appears what you’re after has to do with the registration app.


#6

Try to disable registration app.


#7

Did you even read my thread? I want to let selected users register, but I don’t want the default URL, since it is easy to discover, anyone that knows Nextcloud can easily type the URL and register.

Also I can’t enable 'admin approval 'because of the amount of users I have, it is not possible to manage all the accounts by hand every hour.


#8

Yes, I read it. Please, next time when U want help avoid such a behavior people are here to help.

What U want is called “security through obscurity” and brings you false safety feeling.
You ether have to pre-register your users and give them opportunity to reset pass (search in Forum like bulk users import), or create white list of domains that users email could be connected to, both are possible with NC apps.
Or, try to do some rewerites in Apache/ngnix to change the path of registration URL: e.g. Standart URL brings you back to login page and URL… /pleaseRegisterMe goes to real registration.