How to install latest version of App if not in App Store

Hello all,

I’m installing my first setup of owncloud since I want to transition from google to something more private (e-mails will currently keep running on google). The main feature I will miss is the face recognition from google, so I decided to go for the face recognition app directly in nextcloud.

I’m running nextcloud on an unraid host using the docker container from iamklaus. This starts perfectly smooth for me, however when it comes to install the face app I’m facing the issue, that the app store only offers version 0.7.2, which is only suppored by nextcloud 20, but I’m running nextcloud 22. However, there is a version 0.8.3 which is compatible with nextcloud 22, but I don’t know how to install it. As you can see in the face recognition app this version is shown there but won’t show up in the store.

As you can most likely tell I’m new to nextcloud, I read some tutorials and I read about the face recognition app, but I couldn’t find any explanation what to do. So this might be obvious and I just missed one detail, so please don’t hold back! :wink:

I just tried it the manual way, unfortunately now I’m stuck with the error
“Fatal error: Allowed memory size of 2097152 bytes exhausted (tried to allocate 446464 bytes) in /var/www/html/3rdparty/composer/autoload_real.php on line 37” I increased the memory limit to 4096M and “su - www-data -s /bin/bash -c ‘env’ | grep PHP_MEMORY_LIMIT” confirmes this.

Thank you already for your help

I see a version 0.8.3 for NC 22 on the app store page that you linked.

Memory limit of the php in the web interface and on command line can be different. Check the different config files in /etc/php… (not really sure about docker)

Yes, but the App Store (in my nextcloud instance) was only offering me 0.7.3. But now, after trying this manual setup it seems like 0.8.3 is available there as well. I was able to activate it in the UI, so probably the container came with an old version and the update had to be triggered manually.

for the issue in the config files, I managed to set the memory limit to 4G via an environmental variable. When running phpinfo() I see this information (4G) as well. So, the remaining question is, how do I set this for the command line, it seems to be used for some things, but not for all. I’ll keep trying on this.