How to install Collabora Online in Nextcloud Hub

Originally published at:

Collabora Online is a powerful LibreOffice-based online office suite with collaborative editing, which supports all major documents, spreadsheets, and presentation file formats and works in all modern browsers. The recent release of Nextcloud Hub v19 introduced an easier way to install Collabora Online without Docker or proxy configuration in your web server. On a fresh installation, this is done automatically, but for an existing installation, you have to do the steps manually. It is easy, though, read on to find out how!

View and edit documents directly in your Nextcloud

Collabora Online supports editing your documents in real-time with multiple other editors, showing high fidelity, WYSIWYG rendering and preserving the layout and formatting of your documents.

Users can insert and reply to comments and invite others without a Nextcloud account for anonymous editing of files with a public link shared folder.

Collabora Online supports dozens of document formats including DOC, DOCX, PPT, PPTX, XLS, XLSX + ODF, Import/View Visio, Publisher and many more!

Collabora Online Development Edition (CODE) is free and under heavy development, adding features and improvements all the time! Enterprise users have access to the more stable, scalable Collabora Online Enterprise version through a Nextcloud support subscription.

How to install it on an existing installation?

As already mentioned, on a new installation, this is done automatically, but for an existing installation, you have to do the following steps manually.


1. Install Collabora Online – Built-in CODE Server. (It has to be installed and used together with the Collabora Online app – step 2). This app provides a built-in server with all of the document editing features of Collabora Online. Easy to install, for personal use or for small teams. It is a bit slower than a standalone server and without the advanced scalability features.

Built-in Code server Collabora screenshot

2. Install the **Collabora Online **app.
3. That’s it and you can get to work! If that doesn’t happen, make sure you checked the second option “Use the built-in CODE – Collabora Online Development Edition that is a must step to make it really work!

A few important things to note

Note the following system requirements for the installation:

  • Linux x86-64 platform
  • 2 CPU cores
  • 1 GB RAM + 100 MB RAM / user
  • 100 kbit/s network bandwidth / user
  • 350 MB space on disk
  • Kernel supporting the FUSE (Filesystem in Userspace) which is a requirement for AppImage
  • FUSE 2 ( – required by Collabora_Online.AppImage) is recommended, but the app will work without it too
  • Fontconfig ( – required by Collabora_Online.AppImage)

As already mentioned in step 1, the built-in CODE server has some limitations in terms of performance so if you choose to set up the actual Collabora Online server here is a quick installation guide on how to get started in three steps.


Insert images directly from your Nextcloud. Access the Nextcloud sharing sidebar. Chat or have a call while editing. View and reply to comments.

Mobile and desktop

Collabora Online is not only available in the browser but also on our mobile platforms! Note that you can also edit your documents off-line with the Collabora Office app from the Android and iOS store.

Under your control

Most people use online services for storing their data, communication and editing documents, often giving up control over their files in exchange for the convenience of online collaboration. With Nextcloud and Collabora Online, this is no longer a trade-off.

Collabora Online is Open Source, self-hosted and secure!

If you have problems with any of the apps, have a look at the Nextcloud community support forum.

If you are interested in our Enterprise support options, contact our team here.


:clap:t2: thank you :pray:
Thanks for tell :
CODE is powerful, alright but for the moment it’s the server who does the more work 100MB/sessions, OnlyOffice does it better but things can get better in the future
Thanks again for telling that CODE is open source, his business model behind isn’t the same than OnlyOffice and more of that CODE is cheaper.

Sorry to say it does not work, I have fuse and fontconfig installed but enabling the built-in server failes. It does not log any errors so no clue how to fix it either. The OnlyOffice variant of this app is also still broken, still does not save properly.

Can’t get it to work under docker.

Does it run constantly or on demand? I’d really like the option to have it shut down when not in use because it is rarely used on my server. I do not know yet because I am still on Nextcloud 18 with a docker collabora setup, yes it was a pain setting up ports and forwarding reverse proxies.

i confirm, it dont work in docker.

have updated the proxy config?

A post was split to a new topic: Problem to connect to Collabora

Hey, thanks for the guide!

I have a question to responsiveness of x86-64 vs arm64 which I am currently running on raspberry pi OS (snap on rpi4).

I am seeing some delay int the letters appearing while editing documents on nextcloud. This becomes a problem if I type fast since the inputtet letters may not appear in the correct order, giving typos in almost each word.

if I redo my cloud, I would want to avoid this,
do you avoid this in your setup?

if I try to install the Built-in CODE Server I get an error message “There is an error during the request, it cannot be continued”.
What can I do?

Hi @harley-peter,
You can start a new topic with more information, you will get more help :blush:


Collabora is not working. How fix it?

In log:

Backtrace 11681:

Security: loolmount incorrect user-name, other than ‘lool’
Security: loolmount incorrect user-name, other than ‘lool’
Security: loolmount incorrect user-name, other than ‘lool’


Doesn’t work here either. 2 packages installed but as soon as I try opening a document, it turns like in an infinite loop.

In apache logs I have

Logging at warning level to file: /tmp/loolwsd.nRUsJ84MRx/loolwsd.log 
Failed to listen on Server port(s) (9983-9983). Exiting.

With a random name changing for every new line.
Nothing is created in /tmp/. I already changed the PrivateTmp variable in apache config but it did not fix the issue.

I have a loolwsd process launched by apache but it looks like it’s not doing anything as there is nothing existing in /tmp/ except the .pid file

loolwsd --config-file=/tmp/.mount_Collabifi1NQ/etc/loolwsd/loolwsd.xml --disable-lool-user-checking --port=9983 --lo-template-path=/tmp/.mount_Collabifi1NQ/opt/collaboraoffice6.4 --o:sys_template_path=/tmp/.mount_Collabifi1NQ/ --o:security.capabilities=false --o:security.seccomp=false --o:child_root_path=/tmp/loolwsd.KwXVqgabrO/jails --o:file_server_root_path=/tmp/.mount_Collabifi1NQ/usr/share/loolwsd --o:ssl.enable=false --o:net.proxy_prefix=true[0]=.*[0][@allow]=true --o:memproportion=50 --o:logging.file[@enable]=true[0][@name]=path[0]=/tmp/loolwsd.KwXVqgabrO/loolwsd.log --o:welcome.enable=false --o:mount_jail_tree=false --pidfile=/tmp/

I am having the same problem. Have you by chance come across a solution? I’ve tried reinstalling, using the snap, docker…no matter what I get this same error.

On my side, installed on Debian using Collabora repositories (If you are under ubuntu, try this way instead of snap which can cause random problems. It’s another topic but the few things I tried with snap did not work correctly.)

My server is configured with one name and one alias. Which means the nextcloud is accessible via and the collabora under It probabl helps a bit.

Then edit /etc/loolwsd/loolwsd.xml, here is what I changed on my server

  • Network Settings - proto: IPv4 instead of ALL
  • SSL settings define your certs if using SSL (I’m using the same certs as apache)
  • Backend storage, woopi section, edit the regex to match your setup:

I removed all the others matching 192.168.x.x and all
This last change in the woopi section was one of the main problem I had when opening a document. The web interface was showing a message about a wrong host.

In my apache conf, I added a “site” for collabora using the default template you can find online but as I’m running it using SSL, I replaced every instance of by

As usual, every time you change something, restart loolwsd and apache.

Then in the collabora config page in NextCloud, put your server name like

On my side, before editing it’s conf, loolwsd was not starting properly. Processes were dying after 5 sec.

I am using nextcloud on docker swarm and found that collabora stops to work if I set replicas to more than 1. Just an empty screen.
It didn’t bother me too much to keep as 1.