How to disable request caching in personal setting

HI Everyone,

Is there a way to disable request caching on a personal settings page?

From my testing there seems to be a 1min request cache. If I make a change and refresh the page I still get the old values, but after about a 1min the refresh loads the new values.


You mean settings like the personal profile where you set name, phone number, etc?

I am not aware of any caching there. I can test on my dev instance, though. Are you sure, the caching comes from Nextcloud?

Hi @christianlupus

Not the personal profiles, the personal settings/administration pages. The ‘Connected Accounts’ section, to be specific.

I think its a Symfony or Vue built in mechanism. I’ve check my Nginx config and there is no caching enabled, from what I can tell. And since this is a development machine, I never setup the NC installation with redis, memcache or apcu.

No worries, for now its more of a pain, then a problem, so I just deal with it.