How to debug SMB/CIFS problem?

Hi,

I integrated SMB/CIFS storages in Nextcloud long time ago; I use LDAP for user database and then use “Login credentials, save in session”. This always worked.

Suddenly it stopped. Unfortunately I don’t know when but I guess after upgrading to 10, 11 or 12.

I checked everything: Whole config is unchanged and correct, SMB servers available, smbclient from command line works, nextcloud.log provides not a single entry. smbclient as well as php5-libsmbclient is installed.

In the admin interface, the external storage is red (used to be green).

For the users, I get “
Some of the configured external mount points are not connected. Please click on the red row(s) for more information”.

I tried for 3 hours now finding my way through the source via die("") statements but this just doesn’t go anywhere. How can the verbosity be increased a little bit?


Nextcloud version (eg, 10.0.2): 12.0.3
Operating system and version (eg, Ubuntu 16.04): Debian 8.9
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.10 (Debian)
PHP version (eg, 5.6): 5.6.30-0+deb8u1

The output of your Nextcloud log in Admin > Logging: Not a single entry related to that

<?php $CONFIG = array ( 'updatechecker' => false, 'instanceid' => 'xme8whgfdlkjgsfd', 'passwordsalt' => 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX', 'secret' => 'p+AToFChe/xl4qs+XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX', 'trusted_domains' => array ( 0 => '192.168.1.121', ), 'datadirectory' => '/var/www/nextcloud/data', 'overwrite.cli.url' => 'http://192.168.1.121/cloud', 'dbtype' => 'mysql', 'version' => '12.0.3.3', 'dbname' => 'owncloud', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => 'owncloud', 'dbpassword' => 'XXXXXXXXXXXXXXXX', 'logtimezone' => 'UTC', 'installed' => true, 'ldapIgnoreNamingRules' => false, 'overwritehost' => '127.0.0.1', 'overwritewebroot' => '/cloud', 'mail_from_address' => 'www-data', 'mail_smtpmode' => 'php', 'mail_domain' => 'XXXXXXX', 'theme' => '', 'loglevel' => 2, 'maintenance' => false, 'ldapProviderFactory' => '\\OCA\\User_LDAP\\LDAPProviderFactory', 'updater.secret' => 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX', );