How to close onlyoffice window?

Hello, I have updated Nextcloud to version 18 via the Web-Updater in the meantime and am very happy about the integration of onlyoffice.

When I open a docx document I can edit it directly in the browser. But how can I close the onlyoffice window afterwards when I’m done working and want to go back to the previously displayed file folder?

I cannot find a button for this.

Hi,

Have a look at the top right. On the left hand side, next to the magnifier glass (search feature) there is a close button.

1 Like

I really cant find the button. Here is my screen:

Hi ,
The close button is next to the share button on the top.

2 Likes

Hello,

you can activate the “goback” button.

/apps/onlyoffice/controller/editorcontroller.php
in line 693

693: if ($folderLink !== NULL && $inframe !== 1) {
694: $params[“editorConfig”][“customization”][“goback”] = [
695: “url” => $folderLink
696: ];

@param integer $inframe - open in frame. 0 - no, 1 - yes, 2 - without goback for old editor (5.4)

3 Likes

Nice, thx a lot Dev2. This works!

Thx to ninehyde and Schmu for your help too!

unfortunately this doesn’t work either… I can see the back button now, but when I hit it, the full nextcloud desktop displays in a frame instead of just opening the folder…

I do not have this share button or the X. how to close it then?

Hi tomdrops,

Seems like you have an issue with the ONLYOFFICE App. You may reinstall it.

FYI You should see the close button on top inside the Nextcloud blue bar.

Kr,

I found a solution. Icons are only visible when you tick in OnlyOffice Settings - Open file in the same tab.

@Dev2 works not for me. If i change $inframe form 2 to 1, the button appears. But than - on clicking it - there’S always a new frame with nested only office like mentioned by @tomdrops.
I tried to close the browser and reopen nextcloud but still the same problem. Any more hints?

@POWeber can you post a screenshot?
In @tomdrops post I do see a white X button although it is barely visible in a light grey background.
For me it worked out of the box and has not been affected by any updates so far.


also make sure you have “open file in same tab selected” as recommended by @Jakub_Cieslik POWeber can you post a screenshot?
In @tomdrops post I do see a white X button although it is barely visible in a light grey background.
For me it worked out of the box and has not been affected by any updates so far.
also make sure you have “open file in same tab selected” as recommended by @Jakub_Cieslik

it is a problem with the colour scheme. If i change color to blue, the button is visible.

strange, as notification icon was still visible. Maybe there should be an option to change the colour.

Thx - now i can see the button and i need to change the design only.

Best wishes
POW

@POWeber I am glad it is working on. The notification Icon is part of Nextcloud so it changes color according to the design you select. However the X to close the document is part from Only-Office and I think it always stays white hence not visible in a lighter background