How force to delete folder with space in name

I can’t remove the folder.
— Locally on the server hard drive this folder doesn’t exist, ---- when I’m connected by WWW, folder exists, but option “Delete” disappears
— when I’m using nextCloud local app (linux) when delete, folder magically appeared instantly
I have tried so far:
— cadaver when I use rmcol … show a message: “403 Forbidden”
— cadaver when showlocks: No owned locks
— sudo -u www-data php /var/www/nextcloud/occ files:scan --all <— few times
— config.php in ‘maintenance’ => true, ‘filelocking.enabled’ => false,
, and removed all locks from db.

I have no idea what is going wrong, (maybe that folder contains space ?)