How do I update my configuration to stop using "memcached.sess_lock_wait "

Nextcloud version : 20.0.5
Operating system and version: Ubuntu 18.04.4 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache 2 (unsure of full version)
PHP version: PHP 7.4.11

I’m encountering Internal Server Errors when I try to sync and one of the errors in my log says this:

PHP Startup: memcached.sess_lock_wait and memcached.sess_lock_max_wait are deprecated. Please update your configuration to use memcached.sess_lock_wait_min, memcached.sess_lock_wait_max and memcached.sess_lock_retries at Unknown#0

I’m on a shared system on Dreamhost and I don’t control their php.ini – is there a way to resolve this error locally in my own settings?

Dreamhost provides you with your site’s own php.ini, only it’s called phprc. It’s in a dir called .php (it’s a hidden directory in your home folder, not your site’s folder, so /home/username, not /home/username/websitename. Inside the directory are more directories for different php versions. Since you’re running PHP 7.4, the directory name is 7.4—/home/username/.php/7.4. Inside that directory is the phprc file. Edit that as the php.ini file.

1 Like