How can I setup Nextcloud AIO on a Windows 10 machine with a domain name that updates a dynamic IP via dynu?


Nextcloud version (eg, 20.0.5): AIO v6.4.0
Operating system and version (eg, Ubuntu 20.04): Windows 10
Apache or nginx version (eg, Apache 2.4.25): Not sure
PHP version (eg, 7.4): Not sure, trying to install through Docker

The issue you are facing:

Can’t set it up, since the domain doesn’t correctly forward despite Dynu being setup correctly.
I setup Dynu, which should update the site to the IP address. I added a nextcloud DNS name to it. Then I let 443 and 80 through the firewall both ways, and port forwarded them through my router. I checked on them, and they both appear closed, although I’m not sure why?? Perhaps this is an issue?

When I setup, it made the password for me, and asks for a domain. When I input it gives
DNS config is not set for this domain or the domain is not a valid domain! (It was found to be set to '')
Which I don’t get since the DNS records on Dynu as the domain manager looks fine, with the row looking like: A (XXX.XXX.XXX.123) 120 Edit Disable DNS Record Remove DNS Record

The only thing with Data is the IPv6 AAAA type addresses, but my router doesn’t have an IPv6 address. Maybe I need to use CNAME instead of AAAA?

I’m just learning networking now so any help would be appreciated, I saw that maybe I need to edit apache or nginx files somewhere? Thanks.

Can check whether queries for work and return the expected IP address by doing something like ping from your workstation and/or from an external tool like DNS Lookup | DigitalOcean ?

Thanks for that advice. When I try to access it locally it isn’t working, but also when I try to access the domain on that website, I get the following error:
Uh oh, something went wrong…

The domain you entered isn’t valid.

EDE(9): DNSKEY Missing (no SEP matching the DS found for

I assume that dynu isn’t doing something correctly then or that I haven’t been able to do the correct Dynamic DNS linking then, so I’ll follow up with Dynu. I might have some more questions later since I can’t access it locally either, but I’ll cross that bridge, when I come to it. Thanks for the direction!

1 Like

Okay I checked back today and it seems that it just took some time for dynu to update the domain since now it appears to be working, although when I input the domain it gives a different error which sends me to the logs with an unhelpful error message:

2023-08-09 19:54:24 NOTICE: PHP message: The response of the connection attempt to “” was:
2023-08-09 19:54:24 NOTICE: PHP message: Expected was: 009c06640521f1e3dc984a6582e4e08f80b22eb9e8c37fcd
2023-08-09 19:54:24 NOTICE: PHP message: The error message was: Operation timed out after 10000 milliseconds with 0 bytes received

Here’s the DNS setup on Dynu if it helps.

Do I need to mess with apache or Caddy if I’m using my own domain? I thought that the AIO took care of that. I believe I opened the appropriate ports through port forwarding and through the firewall.

Did you perhaps change your APACHE_PORT from the default?

I ran netstat -ab and also looked at the Inspect tab in docker and they both show that they’re listening to,, and I also see that wslrelay.exe is listening on TCP [::1]:80 as well as 443, 8080, and 8443.

I’m not sure how to check the APACHE_PORT. This is in windows run through docker (so through WSL I think). Would that configuration be in the docker image Files tab? It’s kind of hard to navigate through those all those files. Under /etc/apache2/ I see a bunch of config files, but none that refer to 443, just some that refer to 8080, and an http.d file that seems to be the master, but I haven’t touched it.

When I check environment variables in windows via gci env:* | sort-object name or in the docker image Terminal with set I don’t see APACHE_PORT or anything similar, just a lot of PHP and other variables.

Could Jellyfin have changed it? Or could this instance of apache in docker interact negatively with Jellyfin? Another thing I noticed is that while I can access my jellyfin through the local address on my network with port 8096, I can’t access the AIO startup page on the local address on the network at the 8080 port… I’m not sure why that is. I remember a brief time when I could access it, and now it keeps loading and loading and gives an error.

Just for some closure, I figured out to just follow the AIO directions for a reverse proxy, then I run caddy independently, so I can run it for jellyfin and nextcloud via a very simple Caddyfile, which can be found elsewhere. I’m still figuring out some other issues, but this one is okay!