How can I access Nextcloud with collabora ONLY on local network?

Hi there, I’m trying to get nextcloud setup with collabora using docker on unraid 6.4. However most of the guides I find go into setting up domain names, reverse proxy, and getting certs…I don’t want any of that! I just want it to function on my local network, and IF I access it remotely I will be through my VPN anyway.

How can I simply setup Nextcloud and Collabora without any of the frills?

Follow the guides but don’t set up anything to do with accessing it remotely. You can set up DNS locally on your network, or just access it by IP. It’s also possible to access Nextcloud using a HTTP connection, so this wouldn’t require you to use HTTPS.

I think that’s the key to my issue, but I don’t know how to do that. If I try accessing without HTTPS I just get an error that an http request was sent to an https port or something to that effect.

So how can I go about enabling the ability to use http instead of https?

So disable “HTTP to HTTPS” forwarding?

I dont know how to do that though. I read through the userguide and it spells out some options in the nginx.conf file that need to be disabled, however none of thoes options are present in my config file.

This is the wrror im getting in the nextcloud logs;

GuzzleHttp\Exception\RequestException: cURL error 60: SSL certificate problem: self signed certificate in certificate chain

from what I am reading the best way to fix this is to generate a self signed cert. How would I go bout doing that inside the container? and where would I put it?

Just my 2cents but this seems to be WAY more complicated than it needs to be. SSL should be a highly encouraged option, not mandatory.

What guide are you using?