Hide local "Nextcloud" sync folder, Desktop client

Nextcloud version (eg, 20.0.5): 27.1.0.7
Operating system and version (eg, Ubuntu 20.04): Debian 12.2.0-14
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.57 (Debian)
PHP version (eg, 7.4): 8.2.10

The issue you are facing:
I use local “.Nextcloud” folder as source to be synched to the server. I configured it hidden (leading dot) for not being listed by default. Two subfolders of my home like “Documents” and “Images” are moved there and symlinked to my “/home” to be used as usual and no need for “.Nextcloud” to show up on folders list of my “/home”. This is working as expected for starting but some hours later stops for unknown reason throwing a message like “configuration not valid” in the clients settings GUI.
May be a bug?

Is this the first time you’ve seen this error? (Y/N): ‘Y’

Steps to replicate it:

  1. Se issue above

The output of your Nextcloud log in Admin > Logging:

Just enabled client logging. No items yet

thx

Last time this happened i restarted the client. Did not happen anymore since then.

5 days later issue rising again. Don’t know what to look for at the log. Restarting the client does it.

You are talking about Linux as client operating system? There applications have their settings stored in /home/user/.Appname, and for Nextcloud this should be .config/Nextcloud (Advanced Usage — Nextcloud Client Manual 3.10.0 documentation), not sure in case you use a distribution package if that can be different. It is a bit strange since it says your configuration is not valid.

In the linked document, you can also find how to access the log file, that might give you some more details.

@tflidd
Not sure if we are talking about the same. The config of my linux NC client is residing as excpected at “$Home/.config/Nextcloud/nextcloud.cfg”.

When the client is going to be set up, the local folder to be synched to the server is proposed to be called “Nextcloud” and then is created by the client at “$HOME”. I simply marked it “hidden” by adding a leading dot, moving over two of my subfolders and linked them back to my “$HOME” to keep my well known folder structure. So, when f.ex. a “jpg” is saved to default location like “Bilder” in my case it is in fact going to be saved to “$HOME/.Nextcloud/Bilder” and therefore is synched to the cloud as well.