Help with Android app, please

Hello and good day to you.

I have an instance of Nextcloud through Mail-in -a-box.

I have two separate email accounts and thus two separate cloud accounts.

One account is on a Motorola G4 Plus running AndroidVersion 7.0. This device is connected using the nextcloud app v3.0.3 with DAVdroid 1.10.1.1.

Both apps are from Gplay.

On my new phone, Sony Xperia Ultra, also running version 7.0, I cannot set up the nextcloud app.

When I go through the process, I’m asked to enter the url (https://box.domain.tld/cloud/remote.php/dav) it goes straight to testing the connection and then tells me that the username and password is incorrect.

However, there is no place for me to fill in my credentials. I am able to connect using a web browser but not through the app.

I did a factory reset and started over but I keep getting the same result.

This device replaces a -G2 Motorola where the setup worked.

I have looked for information but have not found anything relevant to the current iteration of Nextcloud.

The version on my server is waiting for the upgrade through the Mail-in-a-box Lavalle package.

Help please - if I’m in the wrong category please redirect me. If I am in the correct category, please direct me to a solution.

Thank you,

Berold B

PS. The current iteration on my box which is not 13.01

Well, the correct URL in your case would be https://box.domain.tld/cloud