Help with AIO docker "Docker socket is not available" error. MacOS

I’m having difficulties using Nextcloud AIO docker, using MacOS Catalina and Docker Desktop. First time I’m trying to use it.

According to the project page (GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.), I am to pull the AIO docker, and use the following script to load it:

sudo docker run -it \
--name nextcloud-aio-mastercontainer \
--restart always \
-p 80:80 \
-p 8080:8080 \
-p 8443:8443 \
--volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
--volume /var/run/docker.sock:/var/run/docker.sock:ro \
nextcloud/all-in-one:latest

Problem seems to be that Docker reports back: “Docker socket is not avilable. Cannot continue”.
Looking at Docker, the AIO docker is loaded but not started. Unable to start. If I start, it stops/exists immediatly and I get the same error message from Docker.

Searching for solutions on DuckDuckGo yields about 5 hits, none of the applicable to this problem. I am not sure where to turn for help or suggestions, other than perhaps if Docker has a forum - which I will check next.

If anyone have any ideas of what causes this problem and how it can be resolved, I’d be grateful. Any suggestions welcome.

Thank you in advance
/A

Hi, did you see this?

@szaimen Hi. Thanks for response. Yes I saw that, and changed the code to fit Macintosh. Also tried it the ‘original’ way, just to see if it worked better, when the Mac way didn’t work for me.
The ‘original’ way didn’t work at all - perhaps not surprisingly - and the Mac way didn’t work because Docker reports there is no socket available.
Presently I’m assuming this means the Mac operative system and Docker cannot communicate, through a ‘socket’. Why this is, I don’t know. Thanks though.