Help up/down files: Encryption not ready

Hi, I have a problem with my nextcloud.
I can’t upload or download files.
every time I try to upload a file it tells me this:

Error loading: Encryption not ready: Default encryption module not loaded

Then I go to the menu on the left > settings as administrator > security
once in security I go to the section:

Server-side encryption
Server-side encryption makes it possible to encrypt files uploaded to the server. This has limitations, such as reduced performance, so only enable this feature if necessary.

enable server-side encryption (it doesn’t let me enable it)

why ? can you help me?

thanks

Did you initially try to setup server side encryption at some point? It’s not on by default so this state shouldn’t happen on its own. (I’m mostly trying to understand whether your goal is to enable server-side encryption or to reverse the state you’re currently in).

Anyhow, we need some basic info like versions, was this Server just installed, etc.

no, the NC server is installed on truenas, it has been active for a week.

Anyhow, we need some basic info like versions, was this Server just installed, etc.

We still need the above to even start to help you out. :slight_smile:

Also, provide the output of:

occ config:list system
occ config:list encryption
occ config:list core

no, the NC server is installed on truenas, it has been active for a week.

Were you ever able to upload or download files since installing?

It sounds like somehow you have encryption partially, but not fully set-up. I’m not sure how that could have happened.

If you haven’t used the installation for any real data yet, you may want to just reset things. But if you provide the above requested output we may be able to reverse things.

root@Next-Cloud-Family:~ #
root@Next-Cloud-Family:~ # occ config:list system
PHP Deprecated: Optional parameter $userId declared before required parameter $path is implicitly treated as a required parameter in /usr/local/www/nextcloud/apps/deck/lib/Service/ConfigService.php on line 234
{
“system”: {
“apps_paths”: [
{
“path”: “/usr/local/www/nextcloud/apps”,
“url”: “/apps”,
“writable”: true
},
{
“path”: “/usr/local/www/nextcloud/apps-pkg”,
“url”: “/apps-pkg”,
“writable”: false
}
],
“logfile”: “/var/log/nextcloud/nextcloud.log”,
“memcache.local”: “\OC\Memcache\APCu”,
“one-click-instance”: true,
“one-click-instance.user-limit”: 100,
“memcache.distributed”: “\OC\Memcache\Redis”,
“memcache.locking”: “\OC\Memcache\Redis”,
“redis”: {
“host”: “REMOVED SENSITIVE VALUE
},
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“localhost”,
" ip truenas",
" my ip publico ",
" server ddns "
],
“datadirectory”: “REMOVED SENSITIVE VALUE”,
“dbtype”: “mysql”,
“version”: “29.0.0.19”,
“overwrite.cli.url”: “http://localhost”,
“dbname”: “REMOVED SENSITIVE VALUE”,
“dbhost”: “REMOVED SENSITIVE VALUE”,
“dbport”: “”,
“dbtableprefix”: “oc_”,
“mysql.utf8mb4”: true,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“installed”: true,
“instanceid”: “REMOVED SENSITIVE VALUE”,
“maintenance”: false,
“twofactor_enforced”: “false”,
“twofactor_enforced_groups”: [
“Family”,
“admin”
],
“twofactor_enforced_excluded_groups”: ,
“memories.exiftool_no_local”: true,
“memories.vod.path”: “/usr/local/www/nextcloud/apps/memories/bin-ext/go-vod-amd64”,
“mail_smtpmode”: “sendmail”,
“mail_smtpsecure”: “ssl”,
“mail_sendmailmode”: “smtp”,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_domain”: “REMOVED SENSITIVE VALUE”,
“theme”: “”,
“loglevel”: 2,
“app_install_overwrite”: [
“ransomware_protection”,
“admin_notifications”,
“files_downloadactivity”,
“files_trackdownloads”,
“vibeetoee”,
"files_external

root@Next-Cloud-Family:~ #
root@Next-Cloud-Family:~ #
root@Next-Cloud-Family:~ #
root@Next-Cloud-Family:~ #
root@Next-Cloud-Family:~ # occ config:list encryption
PHP Deprecated: Optional parameter $userId declared before required parameter $path is implicitly treated as a required parameter in /usr/local/www/nextcloud/apps/deck/lib/Service/ConfigService.php on line 234
{
“apps”: {
“encryption”: {
“enabled”: “yes”,
“encryptHomeStorage”: “1”,
“installed_version”: “2.17.0”,
“masterKeyId”: “master_d79e62f4”,
“publicShareKeyId”: “pubShare_d79e62f4”,
“recoveryKeyId”: “recoveryKey_d79e62f4”,
“types”: "file

root@Next-Cloud-Family:~ #
root@Next-Cloud-Family:~ #
root@Next-Cloud-Family:~ #
root@Next-Cloud-Family:~ # occ config:list core
PHP Deprecated: Optional parameter $userId declared before required parameter $path is implicitly treated as a required parameter in /usr/local/www/nextcloud/apps/deck/lib/Service/ConfigService.php on line 234
{
“apps”: {
“core”: {
“backgroundjobs_mode”: “cron”,
“default_encryption_module”: “yes”,
“emailTestSuccessful”: “1”,
“encryption_enabled”: “yes”,
“files_metadata”: "{"photos-original_date_time":{"value":null,"type":"int","etag":"","indexed\ ":true,"editPermission":0},"photos-exif":{"value":null,"type":"array","etag":" ","indexed":false,"editPermission":0},"photos-ifd0":{"value":null,"type":"array",\ “etag":"","indexed":false,"editPermission":0},"photos-size":{"value":null,"type": "array","etag":"","indexed":false,"editPermission":0},"photos-gps":{"value":null ,"type":"array","etag":"","indexed":false,"editPermission":0},"photos-place":{ "value":null,"type":"string","etag":"","indexed":true,"editPermission":0}," blurhash":{"value":null,"type":"string","etag":"11b77db43d4d9ef2a925d13e2e49cd18","indexed":false,"editPermission" :0}}”,
“files_metadata_installed”: “1”,
“installedat”: “1714839792.0431”,
“lastcron”: “1715261117”,
“lastupdateResult”: “”,
“lastupdatedat”: “1715261159”,

initially, I was able to upload my files.
not anymore since yesterday.

“default_encryption_module”: “yes”,

Did you, by chance, upgrade from a version of Nextcloud Server <v29.0.0 (such as v28.0.4)?