Help testing the 2.2.4 desktop client

Hey!

We just compiled the 2.2.4 desktop client and would be happy for some additional testing before we ship it to the general public.

If you’re interested: Awesome! Any help’s welcome :rocket:

Mac: https://download.nextcloud.com/desktop/prereleases/Mac/Nextcloud-2.2.4.1.pkg
Windows: https://download.nextcloud.com/desktop/prereleases/Windows/Nextcloud-2.2.4.2-setup.exe

Thanks a lot!
Lukas

5 Likes

Unfortunately my problem on macOS remains : it’s impossible to use the Nextcloud client when the server is using TLS 1.2 + strong ciphers (I mean at least AES-128 with GCM mode). The client immediately shows “Connection closed” after a connection attempt (it displayed “SSL handshake error” with the previous version).

Yet the ownCloud client works fine.
There seems to be an issue with the embedded OpenSSL, can’t say more.

1 Like

Linux Client? Deb Packages for Ubuntu/Debian… Please :grin:

5 Likes

it works on windows 10, but… i’m still using the owncloud client on ubuntu… do you know why? :wink:

AppImage? https://github.com/nextcloud/client_theming/pull/29

I’m glad the AppImage exists, however as someone running KDE’s Plasma desktop on Kubuntu, I’d rather not install and permanently have running a whole other version of QT (and other libraries) in the background just to run a desktop sync client. I know packaging for different distros is a pain, but a deb (and rpm, presumably) really would go a long way.

1 Like

Everything works fine on Win 10. When sharing files from web, there is a button send notification(email) but I miss this in app. When sharing files through app, no email is send.

Does not work under OSX 10.7.5 on a MacBook Pro 5,5. No start, crashes.

I’ve updated the website on that. We officially only support 10.9+ at the moment and no older versions. While they may run this is completely untested. (doing so is just uneconomical for us, it requires getting additional devices with older OS X versions as well as performing extensive testing on each.)

Note that everything below 10.9 is end-of-life and won’t receive any form of security patches by Apple. Using anything older is thus a serious security risk.

Yeah, no problem, I went back to owncloud. Too many machines are not the shiny newest things around. I don’t want modernism, I need stability for long-term living hardware.

Installed on macOs Sierra, ok.

I’m glad the AppImage exists, however as someone running KDE’s Plasma
desktop on Kubuntu, I’d rather not install and permanently have running a
whole other version of QT

If you want, you could make an AppImage without Qt…

Same here! Running ubuntu 16.04 with OC.

Probably mentioned already, but there is no 2FA support in both the 2.2.4 desktop application as well as the 1.4.0 Android app.

When you try to login you get either a message with ‘wrong password’ or ‘access denied’

Solution below here.

Edit: @easypeasy You are correct and a hero. I tip my hat to thee :slight_smile:

@Nyana Generate an app-password in your personal settings and you can login again :slight_smile:

1 Like

Let’s close this, the client is out for some time, if you have issues, open a new topic.