Help testing 12.0.7 RC1 & 13.0.2 RC1


#1

Hi,

we just packaged the RCs for our next maintenance releases. They will be available via the “beta” updater channel soon.

The planned release for those versions is next Thursday.

As always - have an backup available and happy testing :rocket:

Download it from the prerelease folder: https://download.nextcloud.com/server/prereleases/

Changelogs

12.0.7 RC1

Apps

13.0.2 RC1

Apps


#2

The update went smoothly without errors. Anything special to look at?


#3

Just check if the use cases you use work fine. :slight_smile:


#4

Hi

Sorry gave limited info;

The install went well, I am using a reverse proxy setup under IIS7 due to using port 443 for another test currently and nextcloud is run from a pre-installed VM all of which resolve externally without a problem. All other links on each page work without error except when logging out…

The use case was fine nothing out of the ordinary.

Is a strange one for sure…, will try out the RC when it’s released to see if this addresses the problem

Thanks
Marco


Logout Issue Error
#5

And obviously I forgot to write where it could be downloaded - from our prerelease folder: https://download.nextcloud.com/server/prereleases/


#6

The automatic web updater worked just fine, never needed the download location.


#7

the web update worked great here :wink:


#8

Debian stretch
Installation nextcloud 13.0.2 RC1
restore config.php

  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' =>
  array (
    0 => 'wolke.systron.de',
    1 => '10.0.0.10',
  ),
  'datadirectory' => '/data',
  'dbtype' => 'pgsql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'db.systron.de',
  'dbport' => '5432',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => 'passwort',
  'installed' => false,
  'default_language' => 'de',
  'force_language' => 'de',
  'memcache.local' => '\OC\Memcache\Redis',
  'redis' => array(
       'host' => '/var/run/redis/redis.sock',
       'port' => 0,
       ),
  'memcache.locking' => '\OC\Memcache\Redis',
  'mail_from_address' => 'root',
  'mail_smtpmode' => 'php',
  'mail_smtpauthtype' => 'PLAIN',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,

restart apache

Technische Details
    Entfernte Adresse: 10.0.0.251
    Anfragekennung: FpwJymP8CLRDK6h790d0

/data/nextcloud.log:

{
    "reqId": "FpwJymP8CLRDK6h790d0",
    "level": 3,
    "time": "2018-04-24T10:04:24+00:00",
    "remoteAddr": "10.0.0.251",
    "user": "--",
    "app": "base",
    "method": "GET",
    "url": "/index.php",
    "message": {
        "Exception": "ErrorException",
        "Message": "session_name(): session.name cannot be a numeric or empty ''",
        "Code": 0,
        "Trace": "
	        #0 [internal function]: OC\\\\Session\\\\Internal->trapError(2, 'session_name():...', '/var/www/html/n...', 175, Array)
	        #1 [internal function]: session_name('')
	        #2 lib/private/Session/Internal.php(175): call_user_func_array('session_name', Array)
	        #3 lib/private/Session/Internal.php(48): OC\\\\Session\\\\Internal->invoke('session_name', Array)
	        #4 lib/base.php(436): OC\\\\Session\\\\Internal->__construct('')
	        #5 lib/base.php(664): OC::initSession()
	        #6 lib/base.php(1081): OC::init()
	        #7 index.php(35): require_once('/var/www/html/n...')
	        #8 {main}",
        "File": "lib/private/Session/Internal.php",
        "Line": 151
    },
    "userAgent": "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0",
    "version": ""
}

#9

For some weird reasons those values are empty in your instance. This is the cause for the failure. Those are set on installation and should not be removed.


#10

I took the old config.php and removed the entries. It should be a
complete fresh installation.
When will this values filled?

I took values from an old config.php an now postgresql is filled.

But firefox show me a blanc side with URL:
https://nextcloud.systron.de/index.php/apps/files/

Last entry in /data/nextcloud.log:

{“reqId”:“zrkXs1ysVil4dvIE9SJU”,“level”:0,“time”:“2018-04-24T12:17:15+00:00”,“remoteAddr”:“10.0.0.251”,“user”:“rag”,“app”:“files_skeleton”,“method”:“POST”,“url”:"/index.php",“message”:“copying
skeleton for rag from /var/www/html/nextcloud/core/skeleton to
/rag/files/”,“userAgent”:“Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
rv:60.0) Gecko/20100101 Firefox/60.0”,“version”:“13.0.2.0”}

And now?


#11

If you want to reinstall, then remove those lines completely and also remove the version. Keep in mind that this is not 100% supported, but should work.


#12

web update did not started.


#13

You have an extra directory in there. Move it out and then it should work fine. We are on it to fix this: https://github.com/nextcloud/updater/issues/68


#14

oh yes all went smooth after removing it was opennms files in folder for data collection.


#15

the redis configuration part stops installation with empty firefox-window:

‘memcache.local’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis.sock’,
‘port’ => 0,
),
‘memcache.locking’ => ‘\OC\Memcache\Redis’,

Is this wrong?


#16

Didn’t had any issu with redis only OpenNMS still can not make that work on Debian stable.


#17

Manual upgrade from 13.0.1 to 13.0.2RC1 went fine. No errors, basic tests revealed no issues.
Debian 9.4 in LXC, Apache, PHP 7.0.27, Redis, PostgreSQL 9.6.

I was hoping that https://github.com/nextcloud/server/issues/6343 would be fixed, my db log files get a bit clogged. Fortunately I’ve just a few users, so I can manage in terms of disk space.
Nice work :+1:


#18

Apr 25 14:33:45 wolke apache2[1131]: [:error] [pid 1131] [client 10.0.0.238:58075] PHP Fatal error: Uncaught Error: Class ‘OC_User’ not found in /var/www/html/nextcloud/lib/private/Log/File.php:104\nStack trace:\n#0 [internal function]: OC\Log\File::write(‘PHP’, ‘Redis::get(): s…’, 3)\n#1 /var/www/html/nextcloud/lib/private/Log.php(321): call_user_func(Array, ‘PHP’, ‘Redis::get(): s…’, 3)\n#2 /var/www/html/nextcloud/lib/private/Log.php(191): OC\Log->log(3, ‘Redis::get(): s…’, Array)\n#3 /var/www/html/nextcloud/lib/private/Log/ErrorHandler.php(90): OC\Log->error(‘Redis::get(): s…’, Array)\n#4 [internal function]: OC\Log\ErrorHandler::onError(8, ‘Redis::get(): s…’, ‘/var/www/html/n…’, 54, Array)\n#5 /var/www/html/nextcloud/lib/private/Memcache/Redis.php(54): Redis->get(‘af0d535e66ac22c…’)\n#6 /var/www/html/nextcloud/lib/autoloader.php(146): OC\Memcache\Redis->get(‘OC_User’)\n#7 [internal function]: OC\Autoloader->load(‘OC_User’)\n#8 /var/www/html/nextcloud/lib/private/Log/File.php(104): spl_autoload_call(‘OC_User’)\n#9 [internal function]: OC\Log\File::write(‘PHP’, ‘Uncaught Error:…’, 3)\n#10 /var/www/htm in /var/www/html/nextcloud/lib/private/Log/File.php on line 104


#19