with Firefox: PR_END_OF_FILE_ERROR


not sure in which category this might fit:
Starting yesterday night, I’m not aware of any change by me, I can’t browse to with Firefox on my OpenSuse box, error is “secure connection failed / PR_END_OF_FILE_ERROR”

Thought at first a site down, but just seen that it works with chromium.

Any hints?


As usual, aunt G. knows the answer:

Same here, also on openSUSE… Refreshing Firefox didn’t help, same as deleting the old profile and starting with a completely new one.

So perhaps a bug/problem with the version distributed by openSUSE.

Have you tried with another browser?

Just after sending my comment above, it started working again… But not always. :see_no_evil:

As said, Chromium on OpenSuse works.
BTW currently writing from mobile, as PC is powerwed off, Sunday :slight_smile:

So just seen that Firefox on Android, latest version, has the same issue.

So IMHO a pure Firefox issue, I’ll report to Firefox community’s bug tracking system.

Thanks to all who answered!

1 Like


Bug for Firefox on Linux:
Bug for Firefox on Android:

same issue with Safari here. It seems deleting cache, cookies helps.

Unfortunately does not help for Firefox. I’ve setup my Firefox, both on Linux and Android, to drop cache and cookies on closure.

FYI, just checked: with Safari on iOS works fine. Firefox on iOS also fails.

WORKS again now.

As NO change on client/browser side, does anyone know what has been changed server side? Would like to close the issues with a meaningful comment :slight_smile:

1 Like

As far as I understood the list of possible root causes the problem is not related to Nextcloud but to an corrupt browser profile, a used VPN, 3rd-party security suites or incorrect cipher variants.

If it would be a general server problem more users had already reported that problem here, so you should question yourself what you’ve changed on your site.

BTW, I’m using Firefox (Win10) without any problems and have never seen that error message.

I also had this issue for some days with Firefox v81.0.1. under Xubuntu.
After some reload attempts i was able to access the help forums.
The page loads without issues in Firefox v81.0.2 since today. No idea when Firefox was updated.

Thinking what I might have changed was my starting point, and as at first only firefox was affected starting in safe mode was the first step tried.

But having got the feedback from #SUSE IRC channel that many all users there who checked for me have been the same error, it’s pretty obvious that this is not an issue on my side, or? Also, as written, all my firefoxes, Linux, Android, and also on an iPhone, all called “firefox” but pretty different pieces of software, have this error. Three “corrupted profiles” etc., at once, and only for ONE website??

Guess not, but nevertheless thank you for trying to help.

P.S.: Just to mention: It works now again on all three devices without having changed anything on all of them, no firefox update etc.

78.3.0esr here, no upate, issue disappeared with same FF version

For me it is also fine again… I’ve just seen that there was an update for uBlock Origin yesterday. So it might have been related to that extension.

It might have been the combination of Firefox and the server configuration. Maybe someone changed the server configuration and tested it in Chrome? :face_with_monocle:

Hey guys, just discovered this thread, I also encounter PR_END_OF_FILE_ERROR when browsing
With Firefox, i cannot access it anymore lately.
with Edge, it will also at first give me PR_END_OF_FILE_ERROR, but then eventually it will reload and work :open_mouth:
So I think it is not only Firefox.
Any updates from “official” side?

I also experience this only on this site so far, so I disagree to say it is a client side problem.

I experience the same error since about a week. I cannot access via Firefox, neither on mobile nor on desktop.

Desktop: Ubuntu 18.04 LTS, Firefox 84.0
Mobile: Android 9, Firefox 84.1.2

Best regards

They currently have a problem with the ipv6 connection not accepting https traffic. I hope they will fix it soon.

btw. the initial problem was solved. So I will close this topic, we have the linked one for the current problem. If this happens again, please use a new topic.