[Help] Nextcloud 11.0.3 syncing with OS X 11.12.4 Contacts sync

Having all sorts of problems talking to My Nextcloud 11.0.3 contacts.

In OSX 10.12.4 Settings I add a new CardDav Account with the following entries

Account Type: Advanced
Server Address: https://MYDOMAIN.COM
Server Path: /nextcloud/remote.php/dav/addressbooks/users/MYUSERNAME/contacts/
Port: ‘Auto’ Use SSL box is ticked

and press sign in. After a few seconds I get the error "Unable to verify account name or password.

I’ve checked my .htaccess file and here are following entries within it


SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1 RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION SetEnvIfNoCase Authorization "(.+)" HTTP_AUTHORIZATION=$1 # Add security and privacy related headers Header set X-Content-Type-Options "nosniff" Header set X-XSS-Protection "1; mode=block" Header set X-Robots-Tag "none" Header set X-Frame-Options "SAMEORIGIN" Header set X-Download-Options "noopen" Header set X-Permitted-Cross-Domain-Policies "none" SetEnv modHeadersAvailable true

Add cache control for static resources

<FilesMatch “.(css|js|svg|gif)$”>
Header set Cache-Control “max-age=15778463”

Let browsers cache WOFF files for a week

<FilesMatch “.woff$”>
Header set Cache-Control "max-age=604800"

php_value upload_max_filesize 511M
php_value post_max_size 511M
php_value memory_limit 512M
php_value mbstring.func_overload 0
php_value always_populate_raw_post_data -1
php_value default_charset 'UTF-8’
php_value output_buffering 0

SetEnv htaccessWorking true

php_value upload_max_filesize 511M
php_value post_max_size 511M
php_value memory_limit 512M
php_value mbstring.func_overload 0
php_value default_charset 'UTF-8’
php_value output_buffering 0

SetEnv htaccessWorking true

RewriteEngine on
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]
RewriteRule ^.well-known/host-meta.json /public.php?service=host-meta-json [QSA,L]
RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]
RewriteRule ^remote/(.) remote.php [QSA,L]
RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.
- [R=404,L]
RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/.*
RewriteRule ^(?:.|autotest|occ|issue|indie|db_|console).* - [R=404,L]

AddType image/svg+xml svg svgz
AddEncoding gzip svgz

DirectoryIndex index.php index.html

AddDefaultCharset utf-8
Options -Indexes

ModPagespeed Off


Header set Strict-Transport-Security "max-age=15552000; includeSubDomains; preload"
Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav


My nextcloud instance is installed on a bog standard Apache2 server in /var/www/html/nextcloud

the .htaccess file is in the nextcloud directory.

I cannot get the contacts working in my iPhone with the same settings and the calendar in OS X and iPhone don’t connect either.

Presumably something really basic is wrong, but I’ll be dammed if I can see what. I have gone through most of the entries on the same topic within the Nextcloud Community as well as

most of the solutions offered are contradictory and refer to older versions of Nextcloud

UFW firewall is turned on and only allows tcp access to ports 22, 443

Any ideas?

Have the same problem. Anyone with an idea or solution?

A solution from alichakery that worked for me is here

Having said that having tried to use the same successful settings used previously on a 5 year old imac and an iphone 7 failed to connect the calendar or contacts on a old iPad 2 with IOS 9.3.5 installed.

I’m unable to explain why this solution works for some hardware, but not others.


It seems to me that Apple devices (iphone, ipad, OSX apps) are looking for the following URLs whatever path is given in CALDAV or CARDDAV parameters.

  • CARDDAV => .well-known/carddav
  • CALDAV => .well-known/caldav

That is why two rewrite rules are included in Nextcloud .htaccess file.

RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]

If your Nextcloud is setup in the “/nextcloud” subdirectory, I suggest that you include the following lines in your web server root .htaccess file.

Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav

Used the same kind of trick since owncloud 8.

Best regards.

Doesn’t work for me.
I had access to my calendar, on both, iPhone and Mac, but now (and i really don´t know why) it´s gone and i ever get the message that Account and/or Passwort could not by verified.
Doe´s anyone have one more hint for me please?

Best wishes

EDIT: That worked now for me. Without all the hassle with :80/:443 or so. Just the htaccess.