Help installing nextcloud 16 on debian 10

After the update to debian 10 from debian 9 my nextcloud quit working. The server was out of date anyway so I tried a reinstall. but all I get at localhost/nexcloud is the following:

  • @author Lukas Reschke * @author Morris Jobke * @author Robin Appelman * @author Thomas Müller * @author Vincent Petry * * @license AGPL-3.0 * * This code is free software: you can redistribute it and/or modify * it under the terms of the GNU Affero General Public License, version 3, * as published by the Free Software Foundation. * * This program is distributed in the hope that it will be useful, * but WITHOUT ANY WARRANTY; without even the implied warranty of * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the * GNU Affero General Public License for more details. * * You should have received a copy of the GNU Affero General Public License, version 3, * along with this program. If not, see * */ // Show warning if a PHP version below 5.6.0 is used, this has to happen here // because base.php will already use 5.6 syntax. if (version_compare(PHP_VERSION, ‘5.6.0’) === -1) { echo 'This version of Nextcloud requires at least PHP 5.6.0
    '; echo 'You are currently running ’ . PHP_VERSION . ‘. Please update your PHP version.’; return; } try { require_once DIR . ‘/lib/base.php’; OC::handleRequest(); } catch(\OC\ServiceUnavailableException $ex) { \OC::$server->getLogger()->logException($ex, array(‘app’ => ‘index’)); //show the user a detailed error page OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE); OC_Template::printExceptionErrorPage($ex); } catch (\OC\HintException $ex) { OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE); OC_Template::printErrorPage($ex->getMessage(), $ex->getHint()); } catch (\OC\User\LoginException $ex) { OC_Response::setStatus(OC_Response::STATUS_FORBIDDEN); OC_Template::printErrorPage($ex->getMessage(), $ex->getMessage()); } catch (Exception $ex) { \OC::$server->getLogger()->logException($ex, array(‘app’ => ‘index’)); //show the user a detailed error page OC_Response::setStatus(OC_Response::STATUS_INTERNAL_SERVER_ERROR); OC_Template::printExceptionErrorPage($ex); } catch (Error $ex) { \OC::$server->getLogger()->logException($ex, array(‘app’ => ‘index’)); OC_Response::setStatus(OC_Response::STATUS_INTERNAL_SERVER_ERROR); OC_Template::printExceptionErrorPage($ex); }

I am sure this is a config issue but I really do not know where to start. I have never had a problem setting up nectcloud in the past. I am a home user, not an IT admin, so patience will be appreciated.

Try reinstalling php. I had the same issue when i upgraded debian 9 to 10.

And i solved it by purging all php packages and reinstalling them.

If you need more help, just be more specific about your install and we can detail it. Otherwise is your best friend.

Since PHP gets upgraded from 7.0 to 7.3 you need to update the related socket or module in the webserver config.

On Apache the following should do:

a2dismod php7.0
a2enmod php7.3

I expect the modules APT package has been installed already via libapache2-mod-php meta package.

In Nginx and Lighttpd with php-fpm there are usually some php handler/socket entries in the config (unix:/run/php/php7.0.sock or similar) that need to be changed to php7.3.