Help for first installation - the "SQLSTATE[HY000][1045] Access denied for user" oddyssey

Hi eyeryone,
today i am here in need of some help while performing my first nextcloud installation. My setup

  • Ubuntu Server 20.04 LTS
  • MariaDB 10.4
  • php7.4
  • Apache2

Webserver and DB all on one system.
I followed the offical guide example for ubuntu installations

I am currently at the “last” step performing installation via the installation wizzard or via occ.
i wanted to install nextcloud via occ, as i plan to use a headless approach for this build.

my tries with occ (later on also via the wizzard) are not successfull, giving me the error:

"Error while trying to create admin user: Failed to connect to the database: An exception occurred in the driver: SQLSTATE[HY000][1045] Access denied for user ‘nextcloud’@‘localhost’ (using password: YES)

So what works:

  • DB is up and running, listening on the default port.
  • I can connect as user “nextcloud” via cli.
  • Even in the usercontext of the www-data “build-in” www-data user i can manually connect to db via cli.
  • mysql/error.log - shows the access attempts of the user which are then denied

So far it looks like something is happening with the provided credentials during the setup - that’s why i tried simple passwords with no specidal characters - no success
i tried several combinations of values for the cli method - hostname / hostname wit port …
afterwards i’ve installed a GUI and browser to access the GUI wizzard. Able to access everything and all worked but i got the same error (which of cause was to be expected)

No i am a bit… idealess what to try next. i would setup the whole server again, but i can’t see any major flaws i’ve been makeing or what could be so wrong that a basic connection to an local DB isn’t working…

What seems to be normal:
Takeing a look into the table mysql.user shows, that the user hast no auth_plugin listed - meaning as far as i was able to read that the user is using the mysql_native plugin.
however - as i am able to connect via cli that seems to be fine.

Anyone hast som ideas how to get this serivce up running?

Thanks in advance!