[Help] Contact import not working

Hello All,
i tried to import some contacts from my phone so i :

  • exported them from the phone via the contact app (Samsung) to vcf file
  • imported via the contact module in Nextcloud

and i have a notification that says : This contact has not been created

Same problem appears when i try to import a single contact.
Are there any logs i can browse to help?

Thanks in advance for your help
Edit : I noticed that this module exports in VCARD 3.0 version and i tried to import with VCARD 2.1. Could it be a version problem?


I had the same problem with an import from thunderbird contacts.

In the vcard file you have to replace all occurences of “version:2.1” with “version:3.0” to make the import work.

If you have special characters in your contacts names you should decode the file before importing. You can do that with an online converter like “http://www.webatic.com/run/convert/qp.php”.
I didn’t convert before importing and had to replace all Umlauts by hand :slight_smile:

All the best,

Hi! We indeed stopped supporting old vcards since #80. You can try @Saskoh’s trick, but we can’t guarantee you won’t get errors from this procedure.