[Help] Add a carddav account to macOS


I’ve read some topics concerning contacts and macOS, but I did not find any solution…
It’s simple as this:

  • I’ve got a shared hosting and NC 13.0.6 installed and running
  • I can sync calendars and files
  • I can’t add a carddav account to macOS 10.12 system preferences : “Unable to verify account name or password”

I tried to use another Contact App (Busycontacts) and everything works fine!
I just entered this URL: https://mydomain.com/remote.php/dav/principals/users/mylogin/

So it seems the issue is from Apple, but is there a way around? Why is it impossible to add a carddav account? I had this issue with owncloud as well…

Sorry if the subject has already been opened… but if someone could sum up the situation, I would be wonderful!

This works for me:

Thanks Bernie,
I have the message: This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.
So I guess service discovery is working, the fact that another app can sync contacts is good to know as well…
Unfortunatly for me your method (automatic configuration, USERNAME@example.xyz) does not work either… Still “Unable to verify account name or password” on macOS
On iOS I succeeded but without SSL… don’t know why :frowning:
but your method concerns caldav, and I do not have the same issue with caldav, just carddav

Here it works with caldav as well as carddav.

Maybe this helps then (this is also caldav, but carddav should be the same):

I tried this already… it works for caldav, but not for carddav :cry:
And it’s not working anymore on iOS…
Thanks for your help anyway

Sorry - running out of ideas… :frowning:

don’t worry, thanks
I tried to deactivate mod_security but it doesn’t change anything

Have you tried with an app password? (in your account settings)
If it sill doesn’t work, this is a duplicate of High Sierra address book does not sync

1 Like

Thank you, I’ll try that and read this thread!
After I deactivated ModSecurity, few days after, carddav was syncing… o_O but the password still has an error in macOS system settings :confused: strange…

THANK YOU ! Creating a specific app password (in settings/security) solved the issue for me. I could not connect from any device (android/macos).

I simply used the url provided in nextcloud ui (https://my.super.domain/remote.php/dav/principals/users/NAME/) and pasted the generated app password.

So simple !

1 Like