Having some trouble with a docker installation and updating

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 26.0.1
Operating system and version (eg, Ubuntu 20.04): docker.io/nextcloud
Apache or nginx version (eg, Apache 2.4.25): n.a.
PHP version (eg, 7.4): n.a.

The issue you are facing:

I’m trying to update to 26.0.2 and when I click the ‘Open Updater’ button in the Admin → Overview, I get a 404 error

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

Not sure exactly how to replicate this so I’ll just tell you what I have done.

The app has been installed and working for a while now but it was slow so I added a redis container and linked it to the nextcloud container via a docker network.

Once I got it up and running again, I tried to run the update but the link just gives me a 404 error.

I am thinking that since it is docker, I can just docker pull the latest container (26.0.2 in this case), but I’m concerned because I have been able to update the installation using the updater before now.

What I did instead was update my compose file to use nextcloud:26.0.1 instead … just in case I was missing files, it would pull the image again.

That didn’t work and the only thing that happened since the last time I updated was that a file system got filled.

Any ideas?

The output of your Nextcloud log in Admin > Logging:

{"reqId":"3Vp0NVy6q608nJQtigyt","level":0,"time":"2023-06-06T04:47:19+00:00","remoteAddr":"","user":"camille","app":"logreader","method":"GET","url":"/index.php/settings/admin/logging","message":"Could not find resource file \"/apps/logreader/css/../js/logreader-main.css\"","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/113.0","version":"","data":{"app":"logreader"},"id":"647eba598b7f3"}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!): PrivateBin

The output of your Apache/nginx/system log in /var/log/____: PrivateBin

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary. PrivateBin

hi @cejfrantz welcome to the forum :handshake:

Please review the right procedure for docker version upgrades

Despite it’s wrong to run an updater I tested this in my installation and I receive 404 as well after click on “open updater”

1 Like

which is great for major version updates … but for minors?

There is no difference in major vs minor upgrade

hmmm … guess i am misremembering then? which is entirely possible … my memory is kinda shot for a while now.


the right upgrade procedure doesn’t mean “it never worked” neither “it’s impossible to upgrade with web updater”… it just does mean it’s designed to work in a specific way…

yep. and i am now updated too! thanks! and fast! (thanks to the redis container)

1 Like