Having issues with Nextcloud Office, built in CODE

tldr: check your wopi whitelist in advanced settings. idk how many other people that applies to, but if it helps even one person, then it’s worth mentioning

I’ve been trying to open an .odt file in Nextcloud, so I initially went in circles across forums trying to diagnose and solve it, as well as attempting my own solutions. Nothing worked, and I ended up managing to make the issue worse. Now selecting “built-in CODE” seems to return an error saying “Could not establish connection”. My setup seems nonstandard [i’m running the server under an ubuntu virtual machine in my home network] so I’m assuming I have some weird network configurations I need to manually adjust, but I know neither what those would be, nor how to adjust them properly.
On that note, any suggestions/requests will likely have to be verbose, since I do not intuitively know how to do something like “Setup a reverse proxy” without guidance. Thank you in advance for your patience

Nextcloud Hub 3 (25.0.2)
Collabora Online - Built-in CODE Server 22.5.802
Nextcloud Office 7.0.2
Ubuntu Server 22.04
Apache 2.4.54
PHP 8.1

1 Like

update: i spun up a test server on a free tier amazon web services server, and besides opening port 9983, I didn’t have to do much for nextcloud office to seemingly work properly. so my conclusion is that i definitely broke something, but i have no clue what I broke, so I will probably attempt to reinstall nextcloud

update 2: i attempted to simply reinstall nextcloud, but nextcloud office still wouldn’t work properly. i’m realizing that whatever i broke broke so badly i’ll need to spin up a fresh vm. fun

update 3: so indeed, i created a new server on a fresh vm, forwarded 9983, and it worked flawlessly. i wish i knew how to fix my previous server, but i haven’t a clue how to even begin trying. so ig it’s time to start transferring everything over

update 4: after a lot of trial and error, I managed to find out that for whatever reason, the culprit is my mariadb database? switching to a fresh database allows nextcloud office to work properly, but switching to my previous database, with my previous account, breaks it. so i guess, i have to deal with switching the database. which i would assume doesn’t change much, just the login credentials

update 5: i would like the last three or so days of my life back. the actual culprit ended up being that i overlooked having made an entry in “Allow list for WOPI requests”. I cleared the list, and was able to properly access nextcloud office again. which, in hindsight, explains why creating a new database worked, but importing my old one didn’t; the new database didn’t have the wopi whitelist.

also, the initial “Could not establish connection” error i was seeing was due to me adding “Listen 9983” to my apache2 ports.conf file, during my frenzied attempts at diagnosing nextcloud office

1 Like