Hansson Nextcloud VM

I downloaded the Hansoon 40GB NC VM from here:

I unzipped the download to get the .ova which I then tar -xvf to yield the two disk files.
I converted these to .qcow2 via qemu-utils to get two files suitable for KVM QEMU (on a CentOS host).
The VM booted but I cannot get networking to work. The interface ens3 does not have an IP address and the link is down. I attached an IPv4 address and brought the interface up. This allows me to ping the local network and to use nslookup to resolve addresses. I can log in to the VM via SSH no problem. I suspected a firewall problem but service ufw stop does not help. Anything like curl or wget just results in ‘network unreachable’ despite the fact that it isn’t. I have tried macvtap, bridged, NAT and all flavours of NIC emulation/routing including E1000/RTL8139/Hypervisor default.
Nothing changed.
In desperation, I suspected that not using the OVF file to create the machine was the problem so I repeated the above with a VirtualBox Oracle setup on Windows 7 x64 which is native for OVF, but this has an identical problem.
I run a lot of VMs and none of them have problems accessing the web.
What is the problem? TIA

Sorry i can not really help you.

But perhaps you like the new minimal Nextcloud AIO.

Click here and then Applicances
Download: https://download.nextcloud.com/vm/Official-Nextcloud-VM.zip
Only (!!!???!!!) 1.6 GB.
You can find it also here at GitHub.

Read from Github:

This is the stripped down version of the full (original) Nextcloud VM. With this you “only” get a clean Nextcloud installation with files, that’s it. No TLS, no automated apps configuration or anything like that - which you do in the full version.

Thanks for the suggestion! In fact I started there but discarded it when I realized that it didn’t contain Talk out of the box, and it is this that I actually want to implement. I run a separate ageing NC 10 VM in a FreeNAS jail for remote file access which I don’t want to meddle with because it works just fine.

It may be easier to just set up a blank debian VM and LAMP / package install it…

1 Like

I had kind of the same problem: I was moving my vmware image from a old laptop to my Qnap.

With ip -br link show I found out the interface was down, with the following 2 commands you can enable the interface and get an IP address. (Where ens3 is the interface name)
sudo ip link set ens3 up
sudo dhclient ens3

After a reboot it will be down again. but now you can go to the webmin interface and edit the nextcloud file in /etc/netplan/
In my case i had to set the interface name correctly.
Now it will keep working. :slight_smile: