Guzzle problem with NC15, PHP 7.2 and Collabora


#1

Recently updated to PHP 7.2 (from 7.0) and since can’T open documents in Collabora anymore. The click on such a document in the browser UI responds with a HTTP code 500 and the server log print this message:

[error] [pid 10510] PHP Fatal error:  Cannot declare class GuzzleHttp\\Exception\\RequestException, because the name is already in use in /var/www/nextcloud/paragon/3rdparty/guzzlehttp/guzzle/src/Exception/RequestException.php on line 0

The same configuration worked in PHP 7.0 so I guess that 7.2 is more strict somewhere but I haven’t found a second instance of GuzzleHttp\\Exception\\RequestException anywhere in the code base.

Any ideas what could be causing this?


#2

Is https://github.com/nextcloud/server/issues/11278 helping?


#3

Sounds promissing, just that I’m behind HaProxy and Apache. But it may help me digging deeper.

EDIT: However, I believe that something with the autoloader of NC must be wrong if anything tries to redeclare a class that only exists once.


#4

I have the same issue with brand new Collabora (Docker) and Nextcloud (Manual) installs on top of Ubuntu 18.04, Apache, MySQL, and PHP.

You didn’t mention whether your Nextcloud works, but mine does. Only the Collabora is broken, with a persistent blank screen and the same error message you provided.

I’ve trawled various threads and none of the solutions have worked. Anyone who can bail me out is a hero. I can provide any other needed information.


#5

@mildapprehension the rest of NC is working perfectly fine, including claendar, contacts, etc.


#6

I can confirm having the same error here.

did anyone already create an issue on github?


#7

Found the solution for my case: I had enabled the proxy module for apache but forgot about proxy_http and proxy_wstunnel. Enabling them too and restarting apache solved the problem here.