Group Folders invisible to Windows NextCloud Synch client

NextCloud v18.0.4
Windows 10 NextCloud client Version 2.6.4stable-Win64 (build 20200303)

Folders made available via Group Folders App are invisible to the Windows 10 synch client.

With same credentials the user can connect to NextCloud via these methods

  • via a regular web browser from Windows
  • via the Android App, and
  • via Webdav using a URL like https://SERVERHOSTNAME/remote.php/dav/files/USERID/

And sees all items made available to the user by:-

  • both conventional Shares,
  • and via Group Folders app.

However when user connects from Windows 10 using the NextCloud synch app only those items made available by conventional shares are visible to the Synch app.

Any suggestions?

External storage and group folders aren’t checked by default in the sync client.

Thanks for this info.
Is there a place to configure different behaviour of the sync client - either client side, or on the server?

If this cannot be addressed by a configuration, then this would seem to be a suitable feature request item?

You can check the box to sync it.

If you mean change the defaults, I think there was an option for that on the client, but I don’t have it in front of me at the moment.

Coming back to this issue, having tested the Client v3.0.2 for Windows.

Regret it is still the same.

  • The only storage we have is in Group Folders. AFAIK the system does not see these as “External storage”
  • In Windows Synch client it is visible for a user in Admin group, and works fine
  • But NOT visible to any regular users not in Admin group

In Settings -> Advanced Settings there is a configuration “Ask for confirmation before synchronising external storages”. I have tried that both Ticked and Unticked, does not allow the regular user to see the Group Folders folder tree.

Meantime the Android client sees what you might expect, the same items which are visible via a regular web browser.

Any insights?
Wisdome gratefully received.

Thanks everyone who responded here.

Finally fixed - problem was an Access control rule in the Workflow area of settings which denied access to all non-Admin users who were using the Desktop client to connect.

No idea why that rule had been put there.

And I will forgive myself for not checking in “Workflow” settings before - I did not realise that these can also include access control rules.

More info here