Group folders App doesn't work anymore - does not create new group folder

Nextcloud 18.0.4
App Group folders 6.0.6

I am trying to create a new group under “Group folders”.
The page reloads after I enter a new folder name and click Create, but nothing happens, no new group folder appears.
But this has worked before.

Before you upgraded something?

See https://github.com/nextcloud/groupfolders/issues for existing issues.

Since I’ve been using the Group folders App, I’ve made several upgrades from Nextcloud in the meantime, so I can’t say if this is related and when it last worked. But it has worked before, because I already have existing group folders… :unamused:

But both Nextcloud and the app have the latest versions at the moment.
It is really annoying that even such basic functions get broken… :angry:

New insights:
Switched to Chrome - there the Group creation worked.
Did not work with Firefox.
Will submit a Github issue… :roll_eyes:

Any blocking/limiting add-ons enabled in FF?

Yes:

  • Ghostery
  • uBlock Origin

How can this interfere?

Don’t know. Script blockers are sometimes evil.
Just disable them for a test if you like.

Have the same versions running here as you and it works here.
Using FF 76.0.1

1 Like

You were right.
After whitelisting my Nextcloud domain in Ghostery the folder creation worked again.
uBlock had no effect.

Thanks for the hint @rakekniven

2 Likes

Just for the record: I had the same Problem.
Problematic extension: “NoScript”, although I already had whitelisted my domain, I had to completely disable the extension to create or edit group folders.

1 Like

I created a new group under “group folders” but users receive an error message: “forbidden” and it is impossible to open folder!

In my case I had to enable pop-ups for my NextCloud site to be able to create a group folder.

(Firefox Options -> Privacy and Security -> Permissions section -> Exceptions button next to “Block pop-up windows”)

1 Like

Nextcloud 19.0.1 running on CentOS (linux Linux 3.10.0-957.27.2.el7.x86_64) with PostgreSQL 9.6.19

This setup has been in production and was running flawlessly for ages.

Recently, I found that when I create a new group folder from the UI, no entry is made into the group_folders table in the database, and no folder is created in the file structure under the __groupfolders top level folder.

As a workaround, I am adding the entry manually directly into the database and manually creating a matching folder. This works fine since at that point everything shows up in the UI. The group folder can be managed, subfolders created etc.

However, this is a production instance and having such a fundamental feature that has been working forever suddenly break is more than a little disconcerting.

I can confirm creating gorup folders works on chromium, but not on firefox (85.0.2 no ghostery, popups allowed). The error in the web console mentions a violated Content Security Policy.

That’s it !!! Thanks, that was driving me crazy

I’m having similar (the same?) problem.

The list of group folders doesn’t show anything. When I add folders, they don’t show up.

Here is how the debugger looks. It says something about javascript not being enabled (which of course it is). Not using any ad blockers, and I’ve activated popups. Tried with chrome and firefox, but same. My Nextcloud is 22.2.0, running through Cloudron:
grafik