Grant Access Loop on Linux Mint 20.1

Hi everyone, newbie here.

I’ve just upgraded my laptop to Linux Mint 20.1. Ever since the upgrade, I cannot connect my nextcloud sync client to my cloud any more, because I get stuck on the “grant access” page (Firefox). After I click the button, the loading icon starts spinning and nothing more happens.

I’ve tried re-installing the client several times, both from the “software manager” and the synaptic package manager - the two clients look slightly different, but they produce the same error.

Does anyone have any suggestions? Is there any more information I can provide? My next troubleshooting step would be switching my OS, which I don’t really want to :frowning:

Best and thanks in advance!

Hello,
Did you try to remove all cookies on Firefox ?

A radical solution would be remove completly firefox & NC and reinstall them with the following commands :

 sudo apt autoremove --purge firefox 
 sudo apt autoremove --purge nextcloud-desktop
sudo apt install firefox nextcloud-desktop