Grannt Access - iOS/Android - not finishing

Hello all,

i hope you are fine.
I asked that question already in the German Subforum, but no answer yet and as i am little under pressure here i wanted to ask this question in the English speaking forum as well.

I do have here a freshly installed Nextcloud instance.
If i try now connect via App to this instance, it stuck at the screen “granting access” after accepting the user/password combination.
There is no error message regarding a timeout. No other error is to be seen either.
In the Logs i am not seeing anything either.
Login via any browser and going through the folders, up/download of files is working fine.

I searched the forum but the usual solutions did not work so i hope you can help me here.
But first the facts:

OS: Ubuntu 22.04.4 LTS
Nextcloud Version: 28.0.2

As i said, with any browser and any of these devices it works fine

Following OS/Apps versiones tried:

iPhone (iOS: 17.3.1)
Nextcloud App Version 5.1.0.7

Android ( 13 - One UI 5.1.1
Nextcloud App Version 3.28.0

Until now i tried the following:

sudo chmod 700 occ
sudo -u www-data ./occ config:system:set overwriteprotocol --value=“https”

Checked the entry within the nextcloud.php

<Directory /var/www/nextcloud/>
AllowOverride All

Was allready given.

Checked the entry within the config.php

‘overwrite.cli.url’ => ‘hxxps://cloud.MeineDomain.de’,
‘overwriteprotocol’ => ‘https’,`

overwrite.cli.url was linked to the direct Ip address, changed it and restarted system, but still the same issue

A blank space within the username could not be the issue, as i am using the e-mail address to login.

While check the log files with:

sudo -u www-data php occ log:watch
there is nothing to see while try to getting access.

If i try to login with a wrong username, i can see that the system is recognizing this as i get the message:

“Warning no app in context…”

I am not sure where to search next.

Attached you will find the config.php file, maybe the issue is there ?

config.php

?php
$CONFIG = array (
‘instanceid’ => ‘xxxx’,
‘passwordsalt’ => ‘xxxx’,
‘secret’ => ‘xxxx’,
‘trusted_domains’ =>
array (
0 => ‘192.xx1.xxx.xxx’,
1 => ‘subdomain.domain.xx’,
2 => ‘proxy.domain.xxg’,
3 => ‘nextcloud-backend.domain.xx’,
4 => ‘192.xx2.xxx.xxx’,
),

‘datadirectory’ => ‘/var/www/html/nextcloud/data’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘28.0.2.5’,
‘overwrite.cli.url’ => ‘https://subdomain.domain.org’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘mysql.utf8mb4’ => true,
‘dbuser’ => ‘nextcloud’,
‘dbpassword’ => ‘xxxxx’,
‘installed’ => true,
‘ldapProviderFactory’ => ‘OCA\User_LDAP\LDAPProviderFactory’,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘filelocking.enabled’ => true,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘localhost’,
‘port’ => 6379,
‘timeout’ => 1.5,
),
‘default_phone_region’ => ‘DE’,
‘mail_from_address’ => ‘noreply’,
‘mail_smtpmode’ => ‘smtp’,
‘mail_sendmailmode’ => ‘smtp’,
‘mail_domain’ => ‘xxxg’,
‘mail_smtphost’ => ‘xxx’,
‘mail_smtpport’ => ‘587’,
‘mail_smtpauth’ => 1,
‘mail_smtpname’ => ‘xxx’,
‘mail_smtppassword’ => ‘xxx’,
‘updater.release.channel’ => ‘stable’,
‘maintenance’ => false,
‘loglevel’ => 2,
‘maintenance_window_start’ => 1,
‘overwriteprotocol’ => ‘https’,

);

thanks in adanvce.

Are you using a reverse proxy or possibly Cloudflare?

Hi,

thanks for the answer.
I am not using cloudflare, but i am using IIS, which means the reuqest goes to the IIS and there is the website “hostest”.

We do have another instance of a nextcloud running in our envoriment (different ip and fqdn) and there it works fine.
I double checked the seeting fpr both sites in the iis, there are the same, except the fqdn etc.