Got stuck while the upgrade process is almost finished

Hi folks, as you can see in this picure, after the usual upgrade steps, after I hit the " * ## Continue with web based updater" button, it got stuck here, it won’t jump to the final upgrade webpage, and after I refresh the upgrater page and click continue, it won’t work.
I checked my config file, it is not on maintence mode, here’s my config file:

<?php
$CONFIG = array (
  'instanceid' => 'XXXXXX',
  'passwordsalt' => 'XXXXXXXXX',
  'secret' => 'XXXXXX',
  'trusted_domains' => 
  array (
    0 => 'XXXXXXX',
  ),
  'datadirectory' => '/srv/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '27.1.5.1',
  'overwrite.cli.url' => 'https://XXXXXX/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'XXXXXXX',
  'dbpassword' => 'XXXXXXXX',
  'installed' => true,
  'filesystem_check_changes' => true,
  'default_phone_region' => 'cn',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.distributed' => '\\OC\\Memcache\\Memcached',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
  ),
  'mail_from_address' => 'XXXXXX',
  'mail_smtpmode' => XXXXX',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'XXXXXXX',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'XXXXXXX',
  'mail_smtpport' => 'XXXXX',
  'mail_smtpname' => 'XXXXX',
  'mail_smtppassword' => 'XXXXX',
  'mail_smtpsecure' => 'ssl',
  'maintenance' => false,
  'loglevel' => 0,
  'theme' => '',
  'app_install_overwrite' => 
  array (
    0 => 'mail',
  ),
  'updater.secret' => '$XXXXXXXXX',
);


in 2024

It looks like occ upgrade does not start automaticaly. That can occure because of your browser or because of a missconfiguration in your webserver.
Try to start it from the command line.
If that does not solve your issue, you have to provide more information about your system.


ernolf

thank you bro, after I delete the memcache config part, the occ upgrade can be exceted again.

Glad you got it working, but memcache parameters should be no problem during an upgrade if it’s working properly. You may want to review your Nextcloud logs since that indicates you may have other problems with your Nextcloud environment that could create other problems if not fixed.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.