Google Integration: no public DNS of my server? Continuous one-way sync?

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 21.0.1
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): nginx/1.18.0
PHP version (eg, 7.4): 7.4.19

The issue you are facing:

I’m running NextCloud in docker-compose from this image: Docker Hub

I’m trying to configure the Google Integration to pull my data from my Google Account.

I installed the Google Integration version 1.0.2 and trying to follow the instructions there, it seems that Google OAuth requires that my NextCloud server have a publicly accessible address.

Is this correct? I can set it up but I was hoping to be able to avoid this, for security reasons.

Another question - once I set up the Google Integration and configure the migration to my user, would NextCloud keep pulling new information from Google or is it a one-off?

My use case is to keep using Google, at least for now, but have a backup on my home NextCloud server.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Installed Google Integration
  2. Follow the instructions on the /settings/admin/connected-accounts page on my NextCloud server
  3. Some of the details in the instructions mismatch what I see on the Google page
  4. For some fields in console.cloud.google.com/apis/credentials/oauthclient e.g. “Authorised JavaScript origins → URIs” and “Authorised redirect URIs → URIs”, Google writes “Invalid origin: Must end with a public top-level domain (such as .com or .org).” when I enter my self hosted home server.

The output of your Nextcloud log in Admin > Logging:

NA - The problem happens when following the instructions to configure things on the Google site.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => '***reducted***',
  'passwordsalt' => '***reducted***',
  'secret' => '***reducted***',
  'trusted_domains' =>
  array (
    0 => 'mac',
  ),
  'dbtype' => 'pgsql',
  'version' => '21.0.1.1',
  'overwrite.cli.url' => 'https://mac',
  'installed' => true,
  'maintenance' => false,
  'dbname' => 'nextcloud_db',
  'dbhost' => 'db',
  'dbuser' => 'postgres',
  'dbpassword' => '***reducted***',
);

The output of your Apache/nginx/system log in /var/log/____:

errors.log is empty, no other log file under this directory.

Thanks.