Gnome Integration

Nextcloud version: I don’t have a nextcloud client on my system
Operating system and version (Linux Mint 19.1):
Apache or nginx version ( Apache 2.4.29):
PHP version (7.2):

Is this the first time you’ve seen this error? (Y):

Steps to replicate it:

  1. Enter nextcloud account in Gnome Online Accounts

  2. Try to open the nextcloud folder in the file browser.

  3. Receiver error message:

    Unable to mount user@server/nextcloud HTTP Error: Found

The output of your Nextcloud log in Admin > Logging:

I don't know that I have such a log

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

I don't have a nextcloud client, do I?

The output of your Apache/nginx/system log in /var/log/____:
I just installed apache and php. The problem persists. But I’m not running a server, and I don’t have to, do I? Anyway, here is the output of

cat /var/log/apache2/error.log
[Fri Mar 22 10:21:07.192944 2019] [core:notice] [pid 31107:tid 140049173150656] AH00094: Command line: '/usr/sbin/apache2'
[Fri Mar 22 11:34:18.532125 2019] [mpm_event:notice] [pid 31107:tid 140049173150656] AH00491: caught SIGTERM, shutting down
[Fri Mar 22 11:34:18.633758 2019] [mpm_prefork:notice] [pid 6571] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Fri Mar 22 11:34:18.634036 2019] [core:notice] [pid 6571] AH00094: Command line: '/usr/sbin/apache2'
[Fri Mar 22 11:34:19.470031 2019] [mpm_prefork:notice] [pid 6571] AH00169: caught SIGTERM, shutting down
[Fri Mar 22 11:34:19.620536 2019] [mpm_prefork:notice] [pid 6634] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Fri Mar 22 11:34:19.620700 2019] [core:notice] [pid 6634] AH00094: Command line: '/usr/sbin/apache2'

Sorry, I can’t be detailed. All I know is that Gnome Accounts accepted my account info:


My file browser (Nemo) displays the netxtcloud network location but it cannot mount it. Nemo handles my google drive fine though.

Please, let me know if I should edit some configuration file or post the contents of some log. Please, be specific as I don’t know my way around well.

You should see a network drive in nautilus or on the desktop in gnome. I have not used it with a dir on the remote server tho. I have only used it with a subdomain. (nc . domain . com and not domain . com / nextcloud)

And from what i can see you should enter and skip the /nextcloud path

This fixed it, thank you. How did you know this is the problem?

I checked with the log information and account name details you added.

To begin, i apologize for my English which is not very good. I hope i’ll be clear to explain my problem.

I’ve just updated my Nextcloud version in 19.0.1.
Since this update, i cannot access anymore to my folder in Nemo.

I use Linux Mint 18.
I’ve tried to create a new application password for my user without success.
However, it runs for the admin user.

I didn’t change anything to my user configuration.

When I add my account in Online Accounts in Mint, it seems to be accepted but when i go to the network drive, i’ve the following message (in french, so i’ve translated it) :

Unable to mount
HTTP Error : Unauthorized

On the desktop of Linux I cannot see the folder to access this network drive but i see the folder for my admin user.

Do you have an idea about the solution ?

Thanks in advance for your help.


Do you use “nextcloud-client” and/or “nextcloud-client-nemo” from or do you use only WebDAV? In the link i found “nextcloud-desktop”. Do you use it? Can it used with Nemo?
Perhaps you can deinstall and reinstall the nextcloud client software. I think there are new versions. Perhaps the old versions are not updated.

List your external PPAs.
List packages for nextcloud:
dpkg -l |fgrep nextcloud

Thanks for your answer.

I don’t use the nextcloud client or desktop app because i don’t want to keep my files on my computer and my SSD is to small to keep all my files. So i transfer them on my nextcloud directly.
It’s more convenient to transfer them from Nemo.

I connect my nextcloud directory in the Online Accounts ever installed in Mint.
To do that :

  • I create an application password in Security in my account (when i’m connected to my nextcloud account in the browser)
  • I go in Online Accounts in Linux Mint
  • I choose Nextcloud in the list
  • I enter th adress of my server (with or without https before the address)
  • I enter my username
  • i paste the password generated by nextcloud
  • It seems to be OK for the connection
  • If i go to nemo I can see my drive as a network drive, but when i click on it i cannot access to it.
  • I’ve got the same config for the user Admin it runs well.

I hope it’s more clear.

I found somethin about this problem.
To access to my cloud from a browser, i’ve created 2 dns redirection.
One with and one with no-ip.

When i’ve tried to put the address linked to no-ip i can access to my files but not when i use the address linked to

However the connection with my admin account is ok with

You find your WebDAV settings in the web-gui on the left side at the button. Use this configuration.

If you want to use the other domain name you must use not forwarding but CNAME for mapping. Also you must re-configure your nextloud and set a new Lets Encrypt certificate. But it is possible.

Thank you for tour answer i’ve tried this too but any change.
So i’ve decided to reinstall my computer because i had some other problems.
Since i’ve reinstalled it i dont have this problem anymore.
I think there is a kind of cache somewhere in Linux but i didn’t find it.
For me m’y problem is solved.

Thanks again for your help

A tipp for further similar problems. You also can only add a new user (/home/user2) or make an empty homedir (/home/user). Mostly it is a user problem and not a system problem. With a new or emty user all userbased settings are deleted.

Yes you’re absolutely right.I don’t think about it.

1 Like