Gmp library error

Hi,

I just installed NextcloudPi image on my raspberry pi 4. I’m trying to install the bookmarks app and I’m getting this error:
App “Bookmarks” cannot be installed because the following dependencies are not fulfilled: The library gmp is not available.

I appreciate if you could help. Thanks.

1 Like

The fix is as easy as it is apparent. Install the php gmp extension :wink:

Is this the right one:
sudo apt-get install libgmp-dev

It should be something like this:
https://packages.ubuntu.com/search?suite=all&searchon=names&keywords=php%20gmp

1 Like

Thanks mate

Hi guys, I got the same error. After I installed the missing library with " sudo apt-get install libgmp-dev"
the error still occurs.

Thanks for support

@ipaschalis Ah, that was the wrong one. it should be something like php{7.1,7.2}-gmp

Still the same error, ist it important to have a gmp version installed?

PHP 7.2.19-0ubuntu0.18.04.2 (cli) (built: Aug 12 2019 19:34:28) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright © 1998-2018 Zend Technologies
with Zend OPcache v7.2.19-0ubuntu0.18.04.2, Copyright © 1999-2018, by Zend Technologies

You probably need to restart the webserver. Something like sudo service apache2 restart

But what if Nextcloud was installed from a snap? “sudo apt install php-gmp” doesn’t install php-gmp into the snap.

Danger alert: if you are running Nextcloud from a ver. 15 snap, don’t upgrade your bookmarks app to 2.1.1! Stay on version 1.1.1

See here for solution.

self install of NC-17 on Ubuntu Server using: https://www.c-rieger.de/nextcloud-installation-guide-ubuntu-18-04/

Saw this notice, too while trying to install the bookmarks app and fixed it via:

sudo apt-get install php-gmp
sudo service php7.3-fpm restart
sudo service nginx restart

2 Likes

If anyone here is a docker wizard, feel free to help out on this pull request: https://github.com/nextcloud/docker/pull/863