Getting webfinger and nodeinfo error despite attempting common solutions

I’m running latest version of nextcloud on my unraid server behind a traefik reverse proxy. When i run the security checks on the Admin settings, i get the webfinger and nodeinfo errors:

  • Your web server is not properly set up to resolve “/.well-known/webfinger”.
  • Your web server is not properly set up to resolve “/.well-known/nodeinfo”.

I’ve looked up the error and found a solution that involved adding the following to the nextcloud .htaccess file

RewriteRule ^.well-known/webfinger /nextcloud/index.php/.well-known/webfinger [R=301,L]
RewriteRule ^.well-known/nodeinfo /nextcloud/index.php/.well-known/nodeinfo [R=301,L]

However this hasn’t fixed the problem, anyone know how to get rid of these errors?

Hello! I get the same message on two of my nextcloud servers and have no idea for resolving …

Are you hosting Nextcloud in a subdirectory rather than on a subdomain by chance?

If so, you’ll need to have counterpart rules on your reverse proxy. That or put your Nextcloud on a subdomain of it’s own and eliminate the subdirectory usage in the URL (which is unnecessary in most cases these days).

My website is hosted at so I’m not sure this is the issue. Perhaps I’ll try putting the rules on traefik anyway. Any idea how to do this on traefik yaml config?

The rules you posted were for a subdirectory deployment - they have /nextcloud/ in the URL.

No, sorry. I don’t use traefik as my reverse proxy.

I just copied the rules from the nextcloud documentation

All good, I guess I’m just going to learn to ignore the error

Just in case this is a common symptom in Nextcloud-29, after upgrading I started getting the same error, however if I test my webfinger using WebFinger I get the public information, so what could be causing the system check to flag it? I’ve also lost all Profiles from Social, which I thought might be related but apparently not.