Getting "Update needed" after trying to restore from backup (21.0.1 > 21.0.0)

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 21.0.0 / 21.0.1
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04.2 LTS
Apache or nginx version (eg, Apache 2.4.25): 2.4.41
PHP version (eg, 7.4): 7.4.3
Database: PostgreSQL

Upgraded Nextcloud from 21.0.0 to 21.0.1 and ran into this bug (Fatal: `Sabre\DAV\Exception` Could not rename part file to final file · Issue #1453 · nextcloud/groupfolders · GitHub) with group folders after the update, which prevents users, who have subsets of group folders shared with them, from uploading into these shares. Waited some time for a fix, then decided to restore the VM snapshot from before the upgrade, which worked fine. Since a lot of data has been added after the upgrade, I wanted to transfer it to the restored instance.

What I did:
As per these guides within the Nextcloud documentation


I deleted all contents of the 21.0.0 data folder and transfered the whole content of the 21.0.1 data folder into it. I dropped the Postgres DB and created it new. I then restored the 21.0.1 DB dump into the 21.0.0 DB.
Regarding the DB I ran into the problem that using the command
PGPASSWORD="password" psql -h [server] -U [username] -d template1 -c "CREATE DATABASE \"nextcloud\";"
produced a permission denied error, while the db drop worked just fine. I fixed it by
sudo -u postgres psql
into the db and creating the db by hand for the old db user. Restoring the db dump by using
PGPASSWORD="password" psql -h [server] -U [username] -d nextcloud -f nextcloud-sqlbkp.bak
then worked fine. I do however have the problem, that when I now try to use adminer to log into the db I get FATAL: Peer Authentication Failed For User.
As for the Nextcloud, when I take the 21.0.0 out of maintenance, I get the Update needed message in CLI and on the web interface as well.

Any ideas what I could do to fix it? Just restoring the old VM and loosing all new data would be a major pain… Thank you so much! :slight_smile: