Getting rid of warnings


I am currently trying to get rid of errors and warning in the logs related to NextCloud.
The current setup is QNAP with MariaDB10, Apache80, NextCloud80 installed.

Version info

Apache/2.4.51 (Unix) OpenSSL/1.1.1l SVN/1.15.0-dev PHP/8.0.14
NextCloud 21.0.7


[Thu Jan 06 16:21:43.265162 2022] [charset_lite:debug] [pid 14866:tid 140198327281408] mod_charset_lite.c(219): [client] AH01448: incomplete configuration: src unspecified, dst unspecified```

output of config.php

$CONFIG = array (
  'hashing_default_password' => true,
  'instanceid' => '###',
  'passwordsalt' => '###',
  'secret' => '###',
  'trusted_domains' =>
  array (
    0 => '',
    1 => 'mypublicURL:45080',
    2 => '',
    3 => 'mypublicURL:45083',
  'version' => '',
  'default_phone_region' => 'DE',
  'datadirectory' => '/share/CACHEDEV1_DATA/.qpkg/NextCloud80/nextcloud/data',
  'dbtype' => 'mysql',
  'overwrite.cli.url' => '',
  'dbname' => 'NextCloud',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_admin',
  'dbpassword' => '#######################',
  'installed' => true,
  'theme' => '',
  'loglevel' => 2,
  'maintenance' => false,
  'updater.secret' => '###',
  'mysql.utf8mb4' => true,

I tried adding these lines to various places without success:

CharsetSourceEnc UTF-8
CharsetDefault   UTF-8

Any ideas?


P.S. I am tracking down more minor problems but one ofetr the other…

wow. you’re a timetraveller? at least you’re pretty much ahead of time… since we common users arte struggeling with nc21, nc22 or nc23 right now :smiley:

apart from that… are there any messages under your admin account - settings - administration - overview - security & setup warnings? would be nice if you would post those

no, the QNAP-package is called like that to indicate PHP80 support.
so as you can see in [Version info] this is 21.0.7

No relevant warnings:

There are some warnings regarding your setup.
No memory cache has been configured. To enhance performance, please configure a memcache, if available. Further information can be found in the [documentation].

But that I left for later as it is PHP related. The current problem is related to Apache’s Source File:
mod_charset_lite.c Status: Extension
Module Identifier: charset_lite_module


It might be worth mentioning the source of my idea how to solve the issue:
official Apache doc:

here it states:

Specifying the same charset for both CharsetSourceEnc and CharsetDefault disables translation. The charset need not match the charset of the response, but it must be a valid charset on the system.

The value “UTF-8” is a valid input for iconv too.